I have a HP 14-AN001NA laptop. It came with Windows 10 installed on which the wifi worked fine anywhere in the house. However I removed windows 10 and installed Ubuntu 16.04 instead and since I have had terrible wifi anywhere aside from about three foot away from the router. I don't know if it's relevant but my wifi is not called wlan0 but wlo1 for some reason (I didn't change it).

When running lspci -knn | grep Net -A3 I get the following output:

05:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8723BE PCIe Wireless Network Adapter [10ec:b723]
DeviceName:  
Subsystem: Hewlett-Packard Company RTL8723BE PCIe Wireless Network Adapter [103c:81c1]
Kernel driver in use: rtl8723be
Kernel modules: wl, rtl8723be
  • Please edit your question and add output of lspci -knn | grep Net -A3 terminal command. – Pilot6 Feb 15 '17 at 16:45
  • I have amended my question. Please help – Blue Dabba Dee Feb 15 '17 at 16:54
up vote 31 down vote accepted

Run in a terminal

sudo tee /etc/modprobe.d/rtl8723be.conf <<< "options rtl8723be ant_sel=1"

and reboot.

The ant_sel parameter enables one of the two antenna connectors of your RTL8723be adapter. Your laptop has only one antenna because the vendor is too greedy to install two. The Linux drivers can't detect which antenna connector is in use. So we have to guess it.

In Windows either the vendor sets it up somewhere on a pre-installed system, or the Windows proprietary drivers can detect it.

If ant_sel=1 does not help, use ant_sel=2. This setting tells which antenna is in use 1 or 2.

  • Brilliant, thank you so much – Blue Dabba Dee Feb 15 '17 at 17:31
  • You may also want to remove a wrong driver by sudo apt purge bcmwl-kernel-source – Pilot6 Feb 15 '17 at 17:42
  • Sorry but the problem has persisted after a fresh install for unrelated reasons. The advice you gave worked earlier but doesn't anymore – Blue Dabba Dee Feb 25 '17 at 18:52
  • Try ant_sel=1 – Pilot6 Feb 25 '17 at 18:57
  • 3
    Works great! But it disconnects randomly. Would you be able to help on how to fix this? I am using Ubuntu 16.04 LTS – Suhail Gupta Oct 21 '17 at 11:11

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.