0

I am running Ubuntu 16.04 LTS on an HP 2560p laptop (64-bit). After finally getting the ALS to work, I have a strange problem with setting brightness using the keyboard keys, with ALS (ambient light sensor) enabled.

On my machine, cat /sys/class/backlight/intel_backlight/max_brightness returns a value of 648. Using the keyboard keys fn + f10 I can increase the brightness, to a maximum value of 616 and still have the display on. If I try to go to the maximum brightness, using the fn + f10 key, my screen goes black. If I run cat /sys/class/backlight/intel_backlight/brightness when the screen is black, it returns the max value of 648.

I can live with this, but it would be nice to have this working correctly. I have intel_backlight which is being used by including "acpi_backlight=vendor" in grub.

I tried to echo 616 > /sys/class/backlight/intel_backlight/max_brightness, to lower the set max brightness to a value I can use, but no dice (can't edit that file and also tried to have it done during boot using rc.local which also didn't work).

If it helps at all, on the low brightness end, I use fn +f9 to decrease bightness. On the lowest achievable level, cat /sys/class/backlight/intel_backlight/brightness returns a value of 8. The indicator bar of the brightness applet, on the lowest brightness setting, still shows a bit, indicating (?) a further decrease in brightness may be possible(?).

Can anyone help with this? I admit I am quite the noob, but when googling for this problem I didn't find a thing. Basically, it seems that the max_brightness value of 648 (set by hardware demands?) is an incorrect value (if that is even possible).

One idea I have as a workaround (although I've no idea how to achieve it) would be to limit the applet function somehow, to reduce its maximum value to 95% of max_brightness (616/648 = 0.95) such that when I use fn + f10 to increase brightness, I will not be able to set it higher than 616 (or 95%).

Any comments or help would be appreciated.

0

So, seems I am on my own here and as a result I've tried to write to the max_brightness file, to decrease the set value of 648 to 616 using echo 616 | sudo tee /sys/class/backlight/intel_backlight/max_brightness. Permission denied.

Re-ran this as root (i.e. after sudo -i), permission denied. So I had the idea to go back to acpi_video0 hoping that the required max_brightness sys file would not be in use thereby allowing me to edit max_brightness (belonging to intel_backlight).

I removed "acpi_backlight=vendor", and all the tweaks for the i915 driver, followed by sudo update-grub, and rebooted. I checked using ls /sys/class/backlight/ and the acpi_video0 folder was again listed (also was intel_backlight).

Then I repeated echo 616 | sudo tee /sys/class/backlight/intel_backlight/max_brightness. Again, permission denied (even as root).

I am guessing since the folder intel_backlight is still listed after ls /sys/class/backlight/, those files are still in use. It would seem to be the case, since cat /sys/class/backlight/intel_backlight/brightness still reports.

Maybe there is a chance I can edit /sys/class/backlight/intel_backlight/max_brightness if I can somehow remove intel_backlight from being listed/reported?

Is there some kind of grub tweak (similar to acpi_backlight=vendor) that would work to kill intel_backlight from loading at boot?

Or would entering recovery mode allow me to edit this sys file (i.e. while offline)?

Anyone?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.