0

I'm on unbuntu 16.04, using ubuntu terminal, running zsh with oh-my-zsh. I'm on a ssh session to a remote computer with the same configuration.

I launched a big computing and forgot to output the result in a file. I thought it was no big deal, I would get the result in the terminal.

But this morning, I can't scroll in my terminal. The mouse wheel just browse the history instead of scrolling, and the scroll bar is all screen long, so can't be moved. The search function just search inside the current window, can't go to previous lines.

In an other tab of the same window, I'm not in an ssh session and there is no problem. Of course I tried to disconnect from the ssh session, but it doesn't solve the problem.

This is the second time it's happening, any idea how to get my results back, and how to avoid it to happen?

  • Try clicking in the terminal windows and pressing some control, shift, alt, and escape. Then hit return. Does this help? Or look in the preferences for the terminal and check that you've actually enabled scrollback. Perhaps whatever you're running is sending crazy control characters to the terminal? – user12753 Feb 15 '17 at 9:38
  • I had another terminal open as well as an other tab open in the faulty terminal, both of them are working well, so no problem with the terminal preferences I think. – Remi Delassus Feb 15 '17 at 9:45
  • I tried all sort of keys combinations with no success – Remi Delassus Feb 15 '17 at 9:45
  • Try pressing escape then i and then try again. – user12753 Feb 15 '17 at 9:45
  • nope, no change – Remi Delassus Feb 15 '17 at 9:46

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.