0

I have a laptop with windows 8.1 pre-installed. To start working on linux, i have installed ubuntu 14.04LTS on it as well(dual-boot). So now whenever i turn on my pc i see the grub screen. Recently i was facing browser hijacking issues(chrome) on windows and decided to use "reset my pc" option in windows. Not facing the browser hijacking issue on windows anymore but now whenever i start my pc, it directly boots to windows. I searched for this problem and found certain solutions such as tweaking the UEFI settings, and I disabled the secure boot option there but still didn't work. help please

  • In Windows, open Disk management. To do This: type: "Create and Format Partitions" in Windows start. After that check if your Ubuntu Partitions still exist. Depending on your Firmware, the partitions may be deleted if the partition table has been rebuilt. If they do exist, make a live boot through a bootable pendrive and run boot-repair. – Aditya Feb 15 '17 at 9:44
  • i ran diskmgmt.msc and opened disk management. the partition is still there mentioned as healthy partition. can you explain the boot-repair step please? – shad0w Feb 15 '17 at 10:00
  • help.ubuntu.com/community/Boot-Repair – user589808 Feb 15 '17 at 16:12
  • 1
    @shad0w I would suggest posting your solution as an answer, and give details from the link you have as part of the answer. That way, you can mark this as solved. – Thomas Ward Feb 15 '17 at 16:44
  • leaving a comment to remind myself to check that this gets edited into a Q&A – Zanna Feb 15 '17 at 16:55
1

The issue has been solved. Because of resetting, the settings were messed up. After running diskmgmt.msc as told by @Aditya I found that the partition was fine, so the issue was with UEFI settings. Here are the steps if you are a windows 8.1 user:

  1. Press windows icon + 'x' on your computer.
  2. Click on Command Prompt(Admin)
  3. Write the following command bcdedit /set {bootmgr} path \EFI\ubuntu\grubx64.efi
  4. Restart and the grub screen should appear again

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.