After upgrading my laptop (Dell Inspiron 5447) to Ubuntu 16.04 I saw that I can't shut down or restart after a few hours using the system. It hangs in Plymouth and stays that way until I force the shutdown by pressing the On/Off button.

As this is a common problem (there are tons of questions on the Internet) I tried to fix it, but none of my attempts were effective. Already tried:

  1. Boot with acpi=force, acpi=noirq and pci=noacpi;
  2. Disabling Swap;
  3. Run 'sync' before reboot or shutdown;
  4. Use another kernel version (4.7, 4.8, 4.9 and 4.10 from mainline);
  5. Disabling USB 3.0 in BIOS setting;
  6. Disabling TLP;

The most interesting thing is:

  1. I can shutdown/reboot normally using 14.04 and the kernel from Xenial HWE;
  2. The system is shutting down/rebooting normally if it doesn't have a considerable uptime (< 2 hours for example);

My Machine Specs:

Dell Inspiron 5447 - BIOS A10 Intel Core i5-4210 Processor 8 GB RAM 480 GB SSD Sandisk Hybrid Graphics (i915/amdgpu - Radeon R7 M265)

Does anyone know how to solve this problem?

  • Add the nosplash option (this disables the boot splash so you can see the informational messages during bootup and shutdown), and when it hangs on shutdown, see what the last few lines are. – QwertyChouskie Feb 15 '17 at 2:57
  • @QwertyChouskie I've already tried that. The system just hangs on "Reboot: Power Down" without any more message. – Renê Barbosa Feb 15 '17 at 11:50
  • Sounds like a low-level issue then... Maybe try clearing the CMOS (unplug the laptop, remove the main battery, remove the small internal button cell, hit the power button a few times, leave the computer alone for a while, and put it all back together)? Also run the ePSA diagnostics (after clearing the CMOS) and see if you have any malfunctioning hardware. – QwertyChouskie Feb 15 '17 at 20:00
  • And also try Mesa 17. – QwertyChouskie Feb 15 '17 at 20:00
  • Hey @QwertyChouskie I Think that's not a low level issue as I can shutdown or reboot normally when I'm not using an Operating System with systemd. For example, Ubuntu 14.04 is running without issues. – Renê Barbosa Feb 21 '17 at 20:21

I got exactly the same problem on Ubuntu 16.04 LTS. After installing amdgpu-pro drivers ver. 492261 system hangs at reboot. Last message printed is: Restarting System

I solved the issue by adding reboot=pci to the list of parameters passed to the kernel:

  • Edit /etc/default/grub
  • Add reboot=pci to the end of GRUB_CMDLINE_LINUX_DEFAULT variable
  • run as root: update-grub
  • reboot (system will hang, turn off/on manually)
  • reboot (this time it will work)

I tried all the suggestions in the other answers and they didn't solve the issue for me.


The problem occurred when the PCI device controlled by the mei_me module was with Runtime Power Management activated.

I got it fixed by adding mei_me module to the RUNTIME_PM_DRIVER_BLACKLIST configuration of TLP.

So, If you have this same problem. It's probably some PCI device with Power Management issues..

  • 2
    Can I ask how did you do that? – Peshmerge Mar 12 '18 at 9:49
  • yes how did you do that? – tatsu Jan 24 at 13:25

I had a similar issue running Ubuntu Server 16.04LTS on Vmware. On shutdown it would "hang" for some time and then proceed to shutdown or reboot. Turns out my host was not configured to do NTP sync, while ubuntu does by default. The host clock was out. As soon as I let the host sync too problem disappeared.

  • 1
    Welcome to Ask Ubuntu! I recommend to edit this answer to expand it with specific details about how to do this. (See also How do I write a good answer? for general advice about what sorts of answers are considered most valuable on Ask Ubuntu.) – David Foerster Jan 4 '18 at 14:51
  • Can you explain how did you solve that? Maybe more details? – Peshmerge Mar 12 '18 at 9:58

I had the same issue after an update and AMD driver update. Try the following:

sudo ubuntu-drivers autoinstall

I had the same issue in 18.04 with an MSI apache laptop (GE62VR GRF Apache Pro, GTX1060, intel core 7 H series).

My solution (I have a dual boot with win10)

For testing: When the computer starts and you have the boot menu press the e key.

I observed that the apci=off option was present. I removed this. Had a successful boot (note this may be a problem for some other hardware configurations that have a tendency to hang when the acpi=off is removed).

Press f10 to boot. This will only be valid for this boot and is not saved or permanent.

After login I then rebooted the system and it worked fine. No hang just went through a standard reboot cycle (pew!).

To make it permanent in grub:

In terminal type sudo nano /etc/default/grub

Locate the line: GRUB_CMDLINE_LINUX=“acpi=off” and comment it out as follows:


I suppose you could also delete the line but I like to track my changes.

Save and close this file.

Then update in terminal with:

sudo update-grub

Next time you start or reboot the system will use these parameters at boot time without you having to change it on the fly.

I hope this is useful to someone out there.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.