0

I have just upgraded to Ubuntu 16.04 on my PC equipped with a Radeon graphic card (chipset RV516) and an LCD screen with VGA connector. I was previously using the proprietary driver fglrx but I have read somewhere that it is not supported on recent Ubuntu versions. So I try to use the open driver radeon.

When booting for the installation support, I got a black screen. I had to use option nomodeset to get the installation working. Now this option is in the kernel options set by grub. If I remove it, the black screen comes back.

What is annoying me is the display resolution I currently have, 640x480, while my display can support 1920x1080. I have found information about the xrandr command. Without parameters, This command returns this:

xrandr: Failed to get size of gamma for output default
Screen 0: minimum 640 x 480, current 640 x 480, maximum 640 x 480
default connected primary 640x480+0+0 0mm x 0mm
640x480    73.00* 

The line about gamma may not be important. The trouble is that xrandr says my screen cannot support more than 640x480. I entered

xrandr --newmode $(gtf 1920 1080 60 |sed -ne 's/"//g;s/ Modeline //p')

then

xrandr --addmode default 1920x1080_60.00

Now xrandr says:

xrandr: Failed to get size of gamma for output default
Screen 0: minimum 640 x 480, current 640 x 480, maximum 1920 x 1080
default connected primary 640x480+0+0 0mm x 0mm
   640x480       73.00* 
   1920x1080_60.00  60.00 

This looks better but then I entered:

xrandr --output default --mode 1920x1080_60.00

which returned:

xrandr: Failed to get size of gamma for output default
xrandr: Configure crtc 0 failed

What should I do now the get another screen resolution working?

0

Its not a real solution, but I also had your situation spendings days researching tons of answers about this thing. The gamma issue turn up often, but I did not see an explanation anywhere. I had exactly the same configuration of a graphics card for 1980 and a monitor setting that said generic and only allowed low res. My card was an intel but I found out that the actual driver had been installed and working. I still got black screen issues and the resolution issue. For me the solution was to install xubunutu-desktop. I did it from the command line

sudo apt update
sudo apt-get install xubuntu-desktop

You can do that an keep your unity desktop. Upon login there is a little option field in the login box where you can select which desktop you want to log in. I did not change anything with the driver and now it works find. Unity should be able to work too, but it just did not do it somehow.

There are other options: - try to boot in failsafeX mode. Grub/Alternative options/recovery then a menu comes up and you select failsafeX. it does replace you driver with a generic software driver, so the desktop becomes horribly slow, but it may be able to give you a diffrent result and you can continue to close down the problem. - you also could boot from a USB/CD live image of Ubunut, Xubunut or whatever flavour. I found that the live images sometimes succeed in hardware recognition of both graphics and monitor. If that works, at least you know that there is no principle conflict.

Should you ever find out more details about this gamma setting please provide the link in your post. The message does not really tell that it is the reason for failure, but at all times I had the gamma message popping up, I could be sure I would end up nowhere. Its quite annoying as the gamma value is so unimportant for most application that any software should be safe to assume a standard value, even a graphics driver. Probable its just a very misleading message for a very different problem.

Hope this helps you along at least a further step.

  • Thanks for your answer. Booting from the live image gives the same behavior. – cfoucher Feb 16 '17 at 21:30
  • I tried installing xubuntu as described. The installation went fine but the issue remained the same. Then I tried the failsafex boot option but to no avail. I could not even get to the login screen. Then after a normal reboot, xrandr was proposing 1024x768, 800x600 and 640x480. I have no idea why these are showing up now and why I still cannot get 1920x1080. – cfoucher Feb 16 '17 at 21:58
  • That is strange that failsafeX does not give you a correct desktop, it should eliminate the typical sources of graphics driver interaction. When you say after a normal boot you get xrandr proposal is that from a text terminal or from an desktop xterm. When my graphics did not work, I also got those resolutions off xrandr (they seem to be related to some fallback or default more). I guess you tried already to add a new resolution by cvt 1920 1080 60 and paste the output from (and including the "...") into xrandr --newmode? Check with lspci -vnn | grep VGA -A 12 if it says "kernel driver in use" – CatMan Feb 17 '17 at 0:00
  • When I got the xrandr proposal, it was from a desktop xterm. But after another reboot, things went back as before to only 640x480. I tried to add a new resolution with xrandr --newmode $(gtf 1920 1080 60 |sed -ne 's/"//g;s/ Modeline //p'). I suppose it would do the same with cvt. – cfoucher Feb 19 '17 at 11:09
  • lspci -vnn | grep VGA -A 12 says Kernel modules: radeon. But lsmod | grep radeon says nothing. I am wondering if the driver has really been loaded. – cfoucher Feb 19 '17 at 11:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.