Recently, after a sudden power failure, my 1tb hard drive (/dev/sda1) failed and will not mount. It says, Error mounting /dev/sda1 at /media/zangar_/4b84d62b-520d-408e-addc-7a2bf52cc4e3: Command-line ``mount -t "ext4" -o "uhelper=udisks2,nodev,nosuid" "/dev/sda1" "/media/zangar_/4b84d62b-520d-408e-addc-7a2bf52cc4e3"' exited with non-zero exit status 32: mount: wrong fs type, bad option, bad superblock on /dev/sda1, missing codepage or helper program, or other error

   `In some cases useful info is found in syslog - try
   dmesg | tail or so.`

I tried e2fsck but it asks me to Get a newer version of e2fsck! Then, I looked at all the other posts about updating e2fsck (here and here.) These answers did not work for me. My problem!

Any help is greatly appreciated, as i have time sensitive documents in the unmountable drive.

up vote 4 down vote accepted

Boot to a Ubuntu Live DVD/USB 16.10 (prefer DVD). It must be 16.10 or higher.

Open a terminal and type sudo fsck -f /dev/sda1.

Now you may be able to mount the drive as normal.

  • Worked like a charm! Thanks – Zangar Feb 14 '17 at 22:48

Using a live CD/DVD/USB seems like a workaround that may not be always applicable.

A believe that the correct answer how to have e2fsck updated is to compile latest version from the sources.

  1. Download the latest version (1.44.3) from http://e2fsprogs.sourceforge.net/ and unpack in a directory and cd into it.

  2. According to the INSTALL document:

    mkdir build; cd build
    ../configure
    make
    sudo make install
    
  3. Check that you have new version now:

    $ e2fsck -V
    e2fsck 1.44.3 (10-July-2018)
    Using EXT2FS Library version 1.44.3, 10-July-2018
    

Note: you may need to install compiler and tools with apt get install gcc.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.