After searching for possible solutions and trying many different things without any success, I decided to ask the community.

I recently built a computer containing a GTX 1050 ti. After installing Ubuntu Studio 16.04 and installing NVIDIA drivers (before they were not shown in the additional drivers list), I tried to play 'Kerbal Space Program', but the performance of the main menu and the start up process of the program were very slow.

I couldn't see the NVIDIA drivers in the Additional drivers tab of settings application, but after adding some other repositories, I finally now can see these three drivers options there: Additional drivers

I tried both of them in my subsequent test glmark2. Both times GL_RENDERER was displayed as Gallium 0.4 on llvmpipe. From my online research (and the glmark2 score of 291), I figured out that the NVIDIA drivers are not being used, even though the NVIDIA drivers were selected in the list of Additional drivers. Here are the outputs from lspci -vnn | grep VGA -A 12 and lshw ->

lspci -vnn | grep VGA -A 12
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GP107 [10de:1c82] (rev a1) (prog-if 00 [VGA controller])
Subsystem: NVIDIA Corporation GP107 [10de:11bf]
Flags: bus master, fast devsel, latency 0, IRQ 16
Memory at f6000000 (32-bit, non-prefetchable) [size=16M]
Memory at e0000000 (64-bit, prefetchable) [size=256M]
Memory at f0000000 (64-bit, prefetchable) [size=32M]
I/O ports at e000 [size=128]
Expansion ROM at 000c0000 [disabled] [size=128K]
Capabilities: <access denied>
Kernel driver in use: nvidia
Kernel modules: nvidiafb, nouveau, nvidia_375_drm, nvidia_375

lshw -class display
   description: VGA compatible controller
   product: GP107
   vendor: NVIDIA Corporation
   physical id: 0
   bus info: pci@0000:01:00.0
   version: a1
   width: 64 bits
   clock: 33MHz
   capabilities: vga_controller bus_master cap_list rom
   configuration: driver=nvidia latency=0
   resources: irq:16 memory:f6000000-f6ffffff memory:e0000000-efffffff memory:f0000000-f1ffffff ioport:e000(size=128) memory:c0000-dffff

1 Answer 1


Disable the nouveau drivers - to do it open a terminal and execute the following command :

sudo nano /etc/default/grub  

Add nouveau.modeset=0 to this line -> GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

that it now reads -> GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nouveau.modeset=0"

Press Ctrl + X to close the file and confirm the change you have made by pressing Y.

Now update the GRUB boot configuration to make this setting active : sudo update-grub

Reboot the operating system, now you use the NVIDIA drivers and nouveau is deactivated.

Update addressing your comment that Gallium 0.4 on llvmpipe is still shown :

Keep the GRUB boot configuration change you've made.

Boot the computer and uninstall the NVIDIA drivers ...

When the login screen appears press Ctrl+Alt+F1.
Enter your user name and the password, then execute :

sudo apt purge nvidia*
sudo poweroff  

Boot the computer and re-install the NVIDIA drivers ...

When the login screen appears press Ctrl+Alt+F1.
Enter your user name and the password, then execute :

sudo apt update
sudo apt install nvidia-375
sudo reboot
  • Will definitely try this out when I can. I thought I had already tried disabling nouveau, but not this way. Thanks
    – Phildor
    Feb 15, 2017 at 11:10
  • Unfortunately, my problem does not seem to be resolved. This is the grub file after reboot: pastebin.com/FTvWTeUdT Running the glmark2 shows again the Gallium 0.4....
    – Phildor
    Feb 15, 2017 at 19:08
  • Well I got it to work, by blacklisting the gallium drivers and then activating the nvidia-378 via the Additional Drivers screen.
    – Phildor
    Feb 17, 2017 at 15:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.