1

I am running xubuntu 16.04.

I have changed my mouse them size to DMZ(White) size 31.

Whenever I restart my system, my mouse cursor resets to the smallest size of 28 (visually).

But when I go to Mouse settings, the setting is still 31. If I toggle the size to 32 and back to 31, the mouse cursor size correctly sets back to 31 (visually).

In addition, the mouse cursor will actually be the correct size on boot up in SOME applications, but not in the desktop.

So my question is two fold.

How can I fix this problem?

Second, if I can not fix it, could I make a start up script that will set the mouse size to 31?

1

Go to /usr/share/icons/default open icon.theme and make sure it contains:

Inherits= Adwaita

close&save

Open a terminal. Using your favourite editor, edit/create ~/.Xdefaults. Add the following text:

Xcursor.theme: Adwaita
Xcursor.size: 32

Save and close the file. Now run:

mkdir ~/.icons 

#if one already exists backup&delete it then recreate

ln -s /usr/share/icons/Adwaita ~/.icons/default

Now reboot.

Then go to the xfce4 mouse&touchpad settings, change to any of the preinstalled cursor themes and your preferred cursor size, reboot to check if it works as it should.

Note: I only tested the solution with the xubuntu&debian preinstalled cursor themes.

3
  • I dunno why this happens, in manjaro-xfce and archlabs-openbox the cursors adjust fine from the GUI, but in debian and xubuntu xfce they dont, probably a distro bug. – siyia Jun 21 '17 at 23:07
  • What does "Then go to the xfce4 mouse&touchpad settings" mean? – Steve3p0 Apr 26 '18 at 3:32
  • Steve -- The "go to" you questioned refers to the "Settings" option of the Whisker menu, which can also be reached via the toolbox icon at the bottom of the Whisker menu. It's the xfce toolbox for adjusting all system settings. – Jim Kyle Apr 30 '18 at 15:10
0

Actually just creating Xcursor.size: 45 in ~/.Xdefaults and a restart did it for me.

I used nano as an Editor so the command is: nano ~/.Xdefaults I added the line all the way to the top.

To write the update back to the file use Ctrl-O and Ctrl-X to end the editor.

Reboot your system.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.