So I encrypted one of my directories using 7z. with a password. When I open it using the GUI it says Password required... what I want is to do this through terminal. First thing I tried was xdg-open but that brought me back to the GUI. When I tried to research this all it gave me was how to unzip the file. Thank you in advance.


You only need the -p parameter for that. So if my password is 123 the line would read

7z x -p123 file.7z
  • Gives me the error: Incorrect command line – Peyto Feb 14 '17 at 1:29
  • Did you even install the p7zip package? – Luis Alvarado Feb 14 '17 at 15:11
  • @Peyto, this is the solution! – George Udosen Feb 14 '17 at 19:45
  • I have it installed and It doesn't work; still gives the error above – Peyto Feb 15 '17 at 3:11
  • @Peyto Please upload an image or the full line you are putting on the terminal and what version of Ubuntu you are using. – Luis Alvarado Feb 15 '17 at 4:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.