10

In Ubuntu 16.10, when my monitors wake up on my 3rd generation Intel Core i7 laptop (HD 4000 graphics), I get flickering on both my built in laptop screen and my external display. It goes away when I bring a full screen window to the front.

It only happens when my screen goes to sleep and then wakes up when I move the mouse. It's not a very serious problem since I just need to move windows or bring them to the front to stop the flickering, but it's annoying and I want to fix it. I would appreciate any help.

  • I have same issue on Ubuntu 17.04 ... does your flicker go away if you put cursor onto empty desktop screen and click and drag on any empty spot ? – Scott Stensland Jul 17 '17 at 21:03
  • Yes, I had that problem. It only happened in Unity, but when I switched to another desktop environment the problem went away. I tried both Cinnamon and Gnome and neither had the flickering problem. I settled on Cinnamon but unfortunately I had other problems running Cinnamon on Ubuntu, so I switched to Linux Mint with Cinnamon installed by default. – Snuggle Bear Jul 18 '17 at 1:17
  • 1
    Just to clarify, by "I had that problem" I meant that clicking and dragging did cause the flicker to go away. – Snuggle Bear Jul 18 '17 at 2:42
  • Same here on a laptop with HD4400 – ndemou Jun 6 '18 at 14:28
8

Make sure you have Compiz installed and enable "Don't wait for video sync" and "Force complete redraw on initial damage"

Compiz -> Utility -> Workarounds -> Don't wait for video sync

Compiz -> Utility -> Workarounds -> Force complete redraw on initial damage

sudo apt-get install compiz compizconfig-settings-manager

I still get one flash but it is significantly better and enabling some of the other workarounds might fix it completely for other people.

  • Thanks for that. I use Linux Mint now which uses the Cinnamon desktop environment and not Unity, so I can't test this out, but I will mark this as the correct answer if this can be confirmed by an Ubuntu Unity user to be a solution to the problem. – Snuggle Bear Sep 9 '17 at 2:25
  • tweaking the compiz utilities sounds like a good tip. although this particular suggestion doesn't solve (yet) my current problem with a Dell ProBook 450 G5 running Ubuntu 16.04 LTS and Unity. I'm playing around further. – Andrea Borga Jun 2 '18 at 7:54
  • update: "something", i.e. changing settings, and restoring the same settings back, "fixed" my flickering... so I'll mark this a "solution" for me. – Andrea Borga Jun 6 '18 at 8:27
  • I was having screen flickering issues with a new 2k external monitor connected to my laptop. This trick seems to have worked for me. Running Ubuntu 16.04 unity, Dell Precision 7510, NVIDIA M1000M graphics + intel chip. – Reilstein Aug 16 '18 at 22:11
0

I had a similar problem using a Benq 24 as an external monitor on a MacBook Pro 5,5 (NVidia graphics). I changed from Ubuntu's all-purpose nouveau driver to the proprietary nvidia driver, and the problem seems to have resolved.

The process is for changing the driver is described in this answer

  • My laptop doesn't have Nvidia graphics, just integrated graphics (Intel HD 4000). – Snuggle Bear Feb 17 '17 at 4:42
  • Even so, if you search for the 'Additional Drivers' panel in the dash, it might offer you a proprietary driver for your Intel HD 4000 in addition to nouveau – vandem Feb 17 '17 at 4:53
  • I am already using "proprietary" for everything listed in "Additional Drivers." There are two items, my Broadcom wireless adapter (which is using proprietary), and "Unknown" which is using Processor microcode firmware for Intel CPUs from intel-microcode (proprietary). For the Unknown one, I don't know if I shouldselect "do not use device" instead, but I'll try it and see if it works. – Snuggle Bear Feb 17 '17 at 20:50
  • No, it didn't work even when I used "do not use device," I still get the flickering after my screen comes back on. – Snuggle Bear Feb 23 '17 at 10:18
  • I don't have the problem anymore, I stopped using Unity and the problem was solved. – Snuggle Bear Mar 13 '17 at 10:26
0

The solution, in my case, was to stop using Unity. I guess this isn't really a solution but more of a workaround.

  • why was this the accepted answer ?... That's not even good as comment and it makes look askubuntu.com users as a bunch of nobs . – Antonio Molinaro Mar 16 '18 at 22:47
  • @AntonioMolinaro I agree, I never should have marked it as an answer. Perhaps someone else might know the answer to this question. – Snuggle Bear Mar 22 '18 at 21:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.