4

I have a dual boot with windows 10 and Ubuntu 14.04 when I boot my PC the windows boot manager shows up and I get the choice between Windows and Ubuntu. The problem is that when I choose Ubuntu, grub shows up and give me the same choice again. This happened since I installed EasyBCD which I later removed. Is there a way to only get grub and not the windows boot manager?

  • Is your system configured to boot with UEFI or CSM (BIOS Legacy Boot)? – WinEunuuchs2Unix Feb 12 '17 at 23:04
  • its configured in csm boot, i have tried uefi but nothing hapenned – Félix Pellerin Feb 14 '17 at 4:53
  • You should not remove Windows boot manager because Windows requires it. The boot entry you see in Grub is simply performing a chain booting from Grub to Windows boot manager. The best thing you could do is change the boot selection delay to zero second so the default boot OS will be booted instantly without giving you the selection option. This option is available to Grub and Windows boot manager, so set the windows boot delay to zero to not see the windows boot manager selection menu. – Bernard Wei Apr 18 at 23:08
0

Make sure Windows Fast Boot is turned off. These instructions are for your CSM boot but you can learn about turning off Fast Boot here: (Installing Ubuntu Alongside a Pre-Installed Windows with UEFI)

On non-UEFI systems or on UEFI systems using CSM (legacy BIOS boot), open the terminal with Ctrl+Alt+T and type:

sudo grub-install --target=i386-pc --recheck /dev/sda
sudo update-grub

This will replace whatever boot manager is on the first HDD or SSD. In rare circumstances where you are booting from the second drive replace sda with sdb

From then on if you make changes to grub, do not reinstall but rather from the terminal use:

sudo update-grub
  • i tried this method, but all it did was changing the order that i see the windows boot manager and grub, now grub shows first, i would like to have only grub and not the windows boot manager – Félix Pellerin Feb 20 '17 at 16:37
  • Just to confirm you only have one hard drive / SSD right? After running install-grub ... run update-grub right away and report if any errors. I modified the answer to reflect this change. – WinEunuuchs2Unix Feb 20 '17 at 17:59
  • yes i only have one hdd and after updating grub no errors are reported – Félix Pellerin Mar 10 '17 at 2:56
0

I had the same issue. First of all change the UEFI boot order by booting into windows and using this tool.

Easy UEFI

http://www.easyuefi.com/index-us.html

open it and Select "Manage Boot order" shift ubuntu until it is at the top.

Now restart your PC if you have a working grub you will be able to boot into Ubuntu if not use a bootable USB(select try ubuntu option) and type the following commands in the terminal to install a brand new Grub.

sudo grub-install --target=i386-pc --recheck /dev/sda sudo update-grub

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.