I decided to upgrade my Ubuntu distribution from 14.04.5 LTS 64-bit to 16.04.5 LTS 64-bit and I did so in the terminal with the following command
sudo do-release-upgrade and I ended up with no GUI, non functional APT and the error failed to start load kernel module just at the start. I somehow managed to make APT functional by running the commands:
sudo apt-get update
sudo dkpg --configure -a
sudo apt-get dist-upgrade
sudo apt-get -f install
apt-get: relocation error: /usr/lib/x86_64-linux-gnu/libapt-pkg.so.5.0: symbol _ZNKSt7__cxx1112basic_stringIcSt11char_traitsIcESaIcEE7compareERKS4_, version GLIBCXX_3.4.21 not defined in file libstdc++.so.6 with link time reference
I do not remember particularly how many times I ran these commands and after that APT seemed to be fixed. The last command comes from this link and I was not able to find the particular file proposed there so I downloaded and installed a later version of that library via dpkg. After all of these I still have lots of broken packages, no GUI and the first four commands above do not seem to fix any issues. Fortunately this is a dual-boot system and GRUB works fine so I can use Windows. On Windows I have burned a CD with 16.04 image thinking it might help somehow. Also looking at the PPAs and 3rd party sources I see all of them are commented out and a string is added to make it obvious that the upgrade procedure commented them out automatically.
Is it possible to restore the GUI and fix the dependencies without much hassle? How should I proceed or should I just wipe the portion of the harddrive containing Ubuntu files(home is mounted on a separate partition) and proceed with a clean install? I have lots of applications and I think most of them will transition relatively smoothly to 16.04 and I would not prefer to install all of them one by one.
EDIT: I managed to remedy the failed to start load kernel module my commenting out the line starting with
rtc in the file
/etc/modules, so one problem is resolved. Although the graphical login interface and the Unity desktop does not work I can start the X server and launch Firefox, text editors, terminal emulator etc.; however, if I minimize them I cannot reach them again as keyboard shortcuts do not work either. The dependency problem is still there and I am thinking of installing all dependencies with dpkg by hand, but apt or dpkg does not even allow removal of some packages(need the new version for new release of some packages) which hinders my capability.
$ sudo apt-get install -f Reading package lists... Done Building dependency tree Reading state information... Done Correcting dependencies... failed. The following packages have unmet dependencies: account-plugin-yahoo : Depends: telepathy-haze but it is not installed empathy : Depends: libcheese-gtk23 (>= 3.4.0) but it is not installable Depends: libcogl15 (>= 1.15.8) but it is not installable Recommends: telepathy-haze but it is not installed Recommends: gnome-contacts but it is not installed Recommends: nautilus-sendto-empathy but it is not installable gnome-system-monitor : Depends: libglibmm-2.4-1c2a (>= 2.36.2) but it is not installable Depends: libgtkmm-3.0-1 (>= 3.8.1) but it is not installable Depends: libsigc++-2.0-0c2a (>= 2.0.2) but it is not installable gstreamer1.0-clutter : Depends: libcogl15 (>= 1.15.8) but it is not installable libbaloofiles4 : Depends: libxapian22 but it is not installable libbalooxapian4 : Depends: libxapian22 but it is not installable libgl1-mesa-dev : Depends: libgl1-mesa-glx (= 12.0.6-0ubuntu0.16.04.1) but 11.2.0-1ubuntu2 is installed libgl1-mesa-glx : Depends: libglapi-mesa (= 11.2.0-1ubuntu2) but 10.1.3-0ubuntu0.6 is installed Breaks: libgl1-mesa-glx:i386 (!= 11.2.0-1ubuntu2) but 10.1.3-0ubuntu0.6 is installed libgl1-mesa-glx:i386 : Breaks: libgl1-mesa-glx (!= 10.1.3-0ubuntu0.6) but 11.2.0-1ubuntu2 is installed libgnomevfs2-dev : Depends: libxml2-dev but it is not installed libnux-4.0-0 : Depends: libsigc++-2.0-0c2a (>= 2.0.2) but it is not installable libqapt2 : Depends: libxapian22 but it is not installable libstdc++6 : Depends: gcc-5-base (= 5.4.0-6ubuntu1~16.04.4) but 5.4.1-2ubuntu1~14.04 is installed libstdc++6:i386 : Depends: gcc-5-base:i386 (= 5.4.0-6ubuntu1~16.04.4) but 5.4.1-2ubuntu1~14.04 is installed ppa-purge : Depends: aptitude (>= 0.6.6-1ubuntu1.2) synaptic : Depends: libxapian22 but it is not installable tasksel : Depends: aptitude (>= 0.2.15-1) vim-gtk : Depends: libperl5.18 (>= 5.18.2) but it is not installable vlc-nox : Depends: libgnutls28 (>= 3.2.10-0) but it is not installable Recommends: libdvdcss2 zeitgeist-core : Depends: libxapian22 but it is not installable E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages. E: Unable to correct dependencies