I'm running an Ubuntu 16.04 (ext4) and Windows 10 (ntfs) dual boot environment which worked perfectly until I seemed to have crashed it by switching temporarily from UEFI Only to Legacy Only in my bios to run hard drive diagnostic tools from USB.

Now the initial splash screen has changed and the grub menu (version 2.02~beta2-36ubuntu3.7) shows up in much lower resolution (640x480) then before.

This is not really a problem for me, but when I choose to start Ubuntu this message pops up for a second:

error: Invalid video mode specification 'text'. Booting in blind mode

Then two more message lines are shown:

[1.895670][drm: intel_set_pch_fifo_underrun_reporting [i915]] *ERROR* uncleared pch fifo underrun on pch transcoder A
[1.895696][drm: intel_pch_fifo_underrun_irq_handler [i915]] *ERROR* PCH transcoder A FIFO underrun

After this, the Ubuntu loading screen appears in high resolution, but exits in emergency mode where I can login as root user.

When I type in glxinfo in Terminal I get Error: unable to open display.

It all seems to me that there is an issue with loading the Intel grahpics driver in Ubuntu (Windows starts without problems).

Has anybody experienced a similar issue before or better can help me to get my Ubuntu booting again? I've searched through the forums, but couldn't find a helpful solution yet. Would be great!

Update @rod-smith (see answer below) helped me already with UEFI/CMS/Legacy settings and got me back to the previous splash screen and the grub menu in high resolution. However, the main problem: error: Invalid video mode specification 'text'. Booting in blind mode still persists and I end up in emergency mode. Any more suggestions how to handle this?

If it helps, I'm running a Lenovo Thinkpad X1 Carbon from 2013.

Update 2 When I run journalctl -xb in emgergency mode, some red messages show up. Within them the messages fsck failed with error code 4 and Failed to Start File System Check on /dev/disk/by-uuid/..... Maybe this can help.

Update 3 The problem is solved. See my answer below.

3 Answers 3


Did you switch back your firmware settings to exactly the way they were before you used the BIOS/CSM/legacy-mode tool? I ask because the error you're reporting is consistent with something in the firmware settings having changed compared to the last time you booted, and this change is causing problems. Note that sometimes changing Option A in the firmware also changes Options B and C, sometimes without warning; and changing Option A back may not change Options B and C, or perhaps might change just one of them. You might look for BIOS-vs-EFI settings relating to the video hardware; perhaps enabling the CSM also set such an option to enable the video hardware's BIOS (vs. EFI) support, and this might be causing problems. A related possibility is that enabling the CSM also enabled (or disabled) a secondary video chipset or video card in the computer. Unfortunately, I can't be more precise about this because such things vary so much from one computer to another, you haven't said what your computer is, and chances are I'm not familiar with it even if you had provided model information. You'll just have to poke around in the firmware setup utility and experiment, unless somebody has a better suggestion.

  • Thanks! That hint didn't solve the problem, but got me further already. When switching to legacy it also switches CSM on and doesn't turn it off again when switching back to UEFI. Now I've got the initial splash screen back and grub shows up in higher resolution again. Also, the drm messages went away and now it just shows Ignoring BGRT: Invalid version 0 (expected 1) which should be harmless after some research. However, its still showing the invalid video mode specification error and still ending up in emergency mode. PS: My system is a Lenovo Thinkpad X1 Carbon from 2013.
    – nrbrt
    Feb 14, 2017 at 9:07

Luckily, I could finally solve my problem. After checking journalctl from emergency mode again a colleague of mine found out that its not my root partition /dev/sda5/ which throws the error message, but my home partition /dev/sda7/. So I run fsck for my home partition again and answered everything with yes. After reboot, the blind mode message was still showing up, but I could boot into Ubuntu.

However, it seemed that fsck messed up a couple of packages as the Unity launcher (toolbar, dash, etc.) didn't show up. So I reinstalled all ubuntu packages with the following command:

for pkg in `dpkg --get-selections | awk '{print $1}' | egrep -v '(dpkg|apt)'`
    apt-get -y --force-yes install --reinstall $pkg

After another reboot Unity still wasn't there, but the blind mode message finally dissapeared!

To get unity back to work, I following the instructions of @jonayad-rahman. However, now my autostart config is gone, but this is a much less serious problem and a good opportunity to clean up a bit... :)


See Error: invalid video mode specification 'text' Booting in blind mode --after invidia installation and update through apt-get update and my reply there, one should probably be marked as a duplicate of the other?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.