When I try starting up Ubuntu 10.04 I get stuck at this screen which is essentially a log in screen but with out the styling of my custom theme. I guess it is running in low graphics mode? Anyways when this log in screen appears I see a message pop up for like 15 seconds in the top right hand corner that reads

Install Problem

The configuration defaults for Gnome Power Manager have not been installed correctly. Please contact your computer administrator.

I will now mention what occurred before my Ubuntu 10.04 would not boot up properly. What I remember doing was installing MongoDB via these instructions. I added the GPG key by running

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv 7F0CEB10

And then I added the following line to my /etc/apt/sources.list

deb http://downloads-distro.mongodb.org/repo/ubuntu-upstart dist 10gen

After this I completed the installation by running the following commands in terminal

sudo apt-get update 
sudo apt-get install mongodb-10gen

While I was going through this process Package Updater popped up saying that it had a bunch of stuff to update. I remember Google Chrome was in the list. I believe I clicked the Install Updates button and off it went. I do not remember if it ever finished updating. I do remember MongoDB installed and after it was done things got weird.

The first thing that was out of place was that a message window popped up saying

The volume “filesystem root” has only 1mb bytes disk space remaining

You can free up disk space by removing unused programs or files, or by moving files to > another disk or partition

I clicked examine and Disk Utility popped up with a kind of pie chart of my disk use. I believe it read that 100% of my disk space was being used. I was like 'What the hell? I did not just dump huge multi gigabyte files on my HD' or did I? I ask this because later on in the #MongoDB IRC chat one of the people there told me that MongoDB's server needs 10gb of space to run and that it starts running right after it gets installed.

Also I noticed that I could not get Google Chrome to open from clicking the icon or via terminal with the command


When I tried to start Chrome in terminal I got and error almost identical to this one

$ google-chrome 
$ [4311:4311:95679337296:ERROR:process_singleton_linux.cc(250)] Failed 
to unlink /home/byers/.config/google-chrome/SingletonLock: Read-only 
file system 
[4311:4311:95679337571:ERROR:process_singleton_linux.cc(265)] Failed 
to create /home/byers/.config/google-chrome/SingletonLock: File exists 
[4311:4311:95679337706:ERROR:process_singleton_linux.cc(250)] Failed 
to unlink /home/byers/.config/google-chrome/SingletonLock: Read-only 
file system 
[4311:4311:95679337746:ERROR:browser_main.cc(1650)] Failed to create a 
ProcessSingleton for your profile directory. This means that running 
multiple instances would start multiple browser processes rather than 
opening a new window in the existing process. Aborting now to avoid 
profile corruption. 

I assume Chrome needs more space to run.

Does anyone have any idea how to solve this problem?


I opened up Terminal and ran df -h and it spit out a table like this


So it looks like my /dev/sda5 partition is in full use.

  • you want to install the chrome and you can't now you want to install chrome right? – VENKI Dec 16 '11 at 17:16
  • no. he has a space problem on one partition.chrome might try to save some temporary files or whatever, which fails because the disk is full. filling important partitions to 100% is one easy way to kill a linux system. Can you please invoke df in a terminal and add the output to your initial posting by editing it? – Michael K Dec 16 '11 at 17:36
  • Sounds as if you are out of hard drive space for ubuntu. – Panther Dec 16 '11 at 17:40
  • @MichaelK ok I updated my post with a link to an image of what df -h printed out. I hope my Linux partition is able to be saved. – max Dec 16 '11 at 19:04
  • I posted a similar question (but more focused around MongoDB) at Stack Overflow stackoverflow.com/questions/8541478/… and sarnold said I might fix it by uninstalling MongoDB. Any ideas if this is the best route? – max Dec 17 '11 at 10:47

I fixed it by deleting the /data/db/ dir which totalled just over 550MB. I can now gain access to Gnome Desktop so all is good but to prevent this problem in the future I am now in the process of increasing my file system root /dev/sda5 from 10G to 25G or more. Better to be safe than sorry.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.