0

I'm newbie to ubuntu and trying to install ubuntu 16.04 into Windows 8 pre-installed desktop PC.

But it seems that something went wrong, and now I cannot boot neither Windows nor ubuntu, and only I can see now is UEFI window.

Followings are what I did so far.


[Ubuntu installation]

  1. I created new partition in my HDD, and disabled fast startup via control panel in Windows.

  2. I installed ubuntu 16.04 via image file in DVD. I chose "try ubuntu without installing" option, and then use "installing ubuntu alongside Windows boot manager" option in GUI installer.

  3. Installation successfully ended, and I rebooted ubuntu.


[First boot problem]

  1. After installing ubuntu, I shutdown ubuntu and boot Windows to check nothing went wrong.

    1.1 At this time, grub normally started, and I could choose OS to be booted (Windows or ubuntu).

  2. However, once I shutdown Windows, grub no longer appeared again. And every time I turned on PC, Windows automatically started to boot.


[Second fatal boot problem]

  1. I followed this thread (Grub not showing on startup for Windows 8.1 Ubuntu 13.10 Dual boot) to solve this problem.

    1.1. I tried following command. But nothing had changed.

    bcdedit /set {bootmgr} path \EFI\ubuntu\grubx64.efi
    
    bcdedit /set {bootmgr} path \EFI\ubuntu\shimx64.efi
    
    bcdedit /set {bootmgr} path \EFI\ubuntu\shim.efi
    
  2. I googled again, and found that sometimes Fast Boot is not properly disabled via control panel in Windows.

    2.1. I opened UEFI menu, and noticed that Fast Boot option was still enabled.

    2.2 I disabled Fast Boot, and (maybe carelessly) disabled Secure Boot option too.

  3. After that, Windows no longer automatically booted, and UEFI option menu automatically opened every time I turned on PC.

    3.1. Further, there was only Windows Boot Manager in the list of Boot Option Priorites (there used to be other options such as DVD disk driver).

  4. I loaded UEFI defaults, but problem still unsolved.

  5. I noticed that CSM option was also disabled, and I enabled it.

    5.1. Then missing other options appeared again in the list of Boot Option Priorities.

    5.2. However, UEFI option menu stopped to automatically open, and window shows

    Reboot and Select proper Boot device
    or Insert Boot Media in selected Boot device and press a key
    

Is there any way to fix it?

NOTES:

  1. I can still boot from ubuntu installation DVD.

  2. My UEFI option menu is "Asrock UEFI Setup Utility"

  • Disabling secure boot shouldn't have prevented Windows from booting. Something wrong happened when you last used Windows before losing the dual boot (some Windows updates are known to do that but, surprisingly, not in UEFI mode). Now, the first thing to do is disable CSM which in this case only makes things worse (Windows may not boot, wait, it really doesn't). Then check again your boot order and if the Ubuntu entry is still there just select it as first priority. If not there then something really wrong happened. – user589808 Feb 12 '17 at 10:59
  • I disabled CSM and rebooted. Now there is only one boot option "Windows Boot Manager". Thank you anyway for your reply! – Kosuke Akimoto Feb 12 '17 at 11:16
  • 1
    You can try this: help.ubuntu.com/community/Boot-Repair – user589808 Feb 12 '17 at 11:26
  • 1
    Or the manual method: askubuntu.com/a/88432/589808 – user589808 Feb 12 '17 at 11:30
  • With CSM disabled do you see the grub menu upon start up now? – Jakob45 Feb 12 '17 at 11:31
0

I finally figure out the root cause of the problem!

After running Boot-Repair program (https://help.ubuntu.com/community/Boot-Repair) as @CelticWarrior suggested, grub menu resumed to open and I could successfully boot any OS (Windows or ubuntu).

However, once I boot and shut down Windows, I have lost access to grub menu again.

It is because somehow Windows changes boot priority so that only its list contains Windows Boot Manager. And to make matters worse, its configuration is incorrect and unable to boot correctly.

Followings are summary of my solution.

[root cause]

  1. Two different EFI systems (that of Windows and ubuntu) are installed in different partition. (Windows in Volume 2, and ubuntu in Volume 6 in my case)

  2. In Windows Boot Manager's configuration, Volume 2 is assumed to contain right EFI (it is true for that of Windows)

  3. However, assumed path for the right EFI is set to that of ubuntu (\EFI\ubuntu\shimx64.efi)!

  4. Since there is no \EFI\ubuntu\shimx64.efi in Volume 2, boot process crash.

[solution]

I checked partition's volume and number using following code in command prompt with admin. (I think you should check which partition contains right EFI system beforehand using standard method)

diskpart
>DISKPART select disk 1
>DISKPART list volume

And assign a letter 'S' to the correct volume (maybe any letter suffice?)

>DISKPART select volume 6 #this is right volume in my case
>DISKPART assign letter=s

After that, I re-configure Windows Boot Manager so that it knows correct path to the EFI system of ubuntu.

bcdedit #check its configuration
bcdedit /set {bootmgr} device partition=s: #set true volume
bcdedit /set {bootmgr} path \EFI\ubuntu\shimx64.efi #actually I omit this line because my boot manager already know this true path

Then I shut down Windows, and now the grub menu opens as I expected!

I hope it will help others with same problem :)

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.