36

enter image description here

dev/sda1: clean, 552599/6111232 files, 7119295/24414464 blocks

After I turn on my laptop this message appears. The system never boots, the message just stays there.

  • 4
    This is a normal startup message. It lets you know that there are no filesystem errors. – heynnema Feb 11 '17 at 20:49
  • 1
    this message does not disappear how can try this solution – El-Dow Feb 12 '17 at 16:24
  • This message is OK. – Pilot6 Feb 12 '17 at 17:09
  • @Pilot6 OK? but how can use OS – El-Dow Feb 12 '17 at 17:28
  • 3
    Oh, I see askubuntu.com/questions/162075/… – Pilot6 Feb 12 '17 at 17:30
21

I have had this problem occur a few times, and every time it was ODDLY Nvidia's fault - yes COUNTER-INTUITIVELY

If in Ubuntu after a long painful reboot run:

sudo apt-get purge nvidia*

or if locked try Ubuntu's awesome way of troubleshooting and try: Ctrl+Alt+F1 through F7 to get to "TTY1-7" and run the same thing. Reboot for good measure, and re-install Nvidia's Proprietary Drivers.

I hope I helped, Mark

  • 3
    Good lord, after trying dozens of other things, this is what eventually worked. – wordsforthewise Nov 25 '17 at 21:18
  • 4
    Please note, that the /dev/sda1:clean message comes from fsck being run at boot time (see answer here). The fact that OP's system wouldn't boot has no relation to the message. Booting issue was likely due to improper graphics driver being used, which is why this answer worked for some people. – Sergiy Kolodyazhnyy Dec 17 '17 at 7:48
  • 1
    But what if we need NVIDIA, e.g. if we're using their GPU? – ComputerScientist Feb 18 '18 at 20:04
  • This answer is nonsense. The OP's problem has nothing to do with the message in the picture or with Nvidia. – mikewhatever May 12 '18 at 23:34
  • 5
    @mikewhatever 🙄 how are you so sure?! This happened to me twice already and it's just after a kernel update. The nvidia module goes missing and the system never finishes booting. Removing the driver (to clean anything that reamined) and then installing it again (thus creating a module for the new kernel) solves the issue. I'd be glad if you can prove it has nothing to do with that and explain us why. This is not "nonsense". – Enrico Jul 2 '18 at 22:57
7

ctrl+alt+f2 or f3

  • login with your account
  • type sudo apt-get update (enter password when prompted)
  • type sudo apt-get install xserver-xorg-video-intel
  • reboot
  • or type journalctl and check what is going on there – swietyy Oct 16 '18 at 16:56
1

I am not sure if this will work for everyone but I managed to fix this by removing every occurrence of nomodeset from /etc/default/grub file and then by executing sudo update-grub.

This was because nomodeset disables the use of any graphic driver. I disabled my nouveau drivers before installing nvidia ones.

Though this might not be the case with everyone.

  • Thanks, yes that make sense too. I have alienware 13 R-3, To install ubuntu I added nomodeset to enable ubuntu os to load. Once I installed nvidia driver, I was getting the above error. So on grub I pressed e for edit and removed the nomodeset and ctrl+x to rebboot. After that I got desktop all fine. – Mian Asbat Ahmad Mar 11 at 13:31
0

Step #1

Lets first check your file system for errors.

To check the file system on your Ubuntu partition...

  • boot to the GRUB menu
  • choose Advanced Options
  • choose Recovery mode
  • choose Root access
  • at the # prompt, type sudo fsck -f /
  • repeat the fsck command if there were errors
  • type reboot

If for some reason you can't do the above...

  • boot to a Ubuntu Live DVD/USB
  • start gparted and determine which /dev/sdaX is your Ubuntu partition
  • quit gparted
  • open a terminal window
  • type sudo fsck -f /dev/sdaX # replacing X with the number you found earlier
  • repeat the fsck command if there were errors
  • type reboot

Step #2

If step #1 doesn't fix your problem, then do this...

  • boot to the GRUB menu
  • choose Advanced Options
  • choose Recovery mode
  • choose Root access
  • at the # prompt, type:
    • sudo blkid
    • sudo cat /etc/fstab
  • edit your question to include the output from the two previous commands
  • type reboot

Step #3

pending fix here...

Step #4

If you dual-boot with Windows, then do this in Windows...

  • open the Power control panel
  • click on change what the power buttons do
  • click on change options that are unavailable
  • uncheck fast start
  • close the Power control panel
  • open an administrative command prompt window
  • type powercfg /h off (turns off hibernation)
  • type chkdsk /f c:
  • approve that chkdsk runs at next boot time
  • reboot Windows
  • Run these steps and tell me the result, and I'll finish the answer with the final fix. – heynnema Feb 13 '17 at 21:32
  • I have the same problem, it shows me the same /dev/sda1: clean..... message when I run the sudo fsck command. I type fsck and then reboot, however the problem still persists. I am not dual booting, I intend to have one OS that is Lubuntu on my 8 yr old netbook. Can you suggest what to do next – Transistor Overlord Dec 1 '17 at 16:03
  • @TransistorOverlord please start a new question. Provide as much detail as possible. Describe exactly what you've tried to fix the problem. – heynnema Dec 1 '17 at 16:29

protected by Community Sep 23 '17 at 20:52

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.