129

enter image description here

dev/sda1: clean, 552599/6111232 files, 7119295/24414464 blocks

After I turn on my laptop this message appears. The system never boots, the message just stays there.

19
  • 12
    This is a normal startup message. It lets you know that there are no filesystem errors.
    – heynnema
    Feb 11, 2017 at 20:49
  • 3
    this message does not disappear how can try this solution
    – El-Dow
    Feb 12, 2017 at 16:24
  • 3
    Oh, I see askubuntu.com/questions/162075/…
    – Pilot6
    Feb 12, 2017 at 17:30
  • 3
    For those folks who tried installing lightgdm and didn't work, you might see a message /dev/nvme3/: clean and you waited for a long time. Try these commands. (Alt + F2 to login, if you are still stuck). sudo service gdm3 status (in you case it might be gdm) If its not already running try: sudo service gdm3 start
    – Smit Patel
    Apr 18, 2020 at 7:46
  • 7
    Worked for me: sudo apt-get install --reinstall ubuntu-desktop Dec 19, 2020 at 22:01

18 Answers 18

85

I have had this problem occur a few times, and every time it was ODDLY Nvidia's fault - yes COUNTER-INTUITIVELY

If in Ubuntu after a long painful reboot run:

sudo apt-get purge nvidia*

or if locked try Ubuntu's awesome way of troubleshooting and try: Ctrl+Alt+F1 through F7 to get to "TTY1-7" and run the same thing. Reboot for good measure, and re-install Nvidia's Proprietary Drivers.

11
  • 17
    Please note, that the /dev/sda1:clean message comes from fsck being run at boot time (see answer here). The fact that OP's system wouldn't boot has no relation to the message. Booting issue was likely due to improper graphics driver being used, which is why this answer worked for some people. Dec 17, 2017 at 7:48
  • 4
    But what if we need NVIDIA, e.g. if we're using their GPU? Feb 18, 2018 at 20:04
  • 8
    @mikewhatever 🙄 how are you so sure?! This happened to me twice already and it's just after a kernel update. The nvidia module goes missing and the system never finishes booting. Removing the driver (to clean anything that reamined) and then installing it again (thus creating a module for the new kernel) solves the issue. I'd be glad if you can prove it has nothing to do with that and explain us why. This is not "nonsense".
    – Enrico
    Jul 2, 2018 at 22:57
  • I'd be glad to prove it, if you can arrange access to your PC for evaluation. Without that, asking for something like that poses an impossible task. The nvidia module should get auto-rebuilt by dkms after a kernel update. It's been working for me for many years on multiple PCs with different Nvidia cards. I've never ever had to remove the driver and reinstall. Jul 6, 2018 at 17:57
  • 2
    Wow, it worked. I actually was thinking of removing Nvidia, but it was a little further down on my list, just under "Open computer case and jiggle some wires to see if anything was loose" and "apply hammer to motherboard with extreme force". Glad I found this post because I'd exhausted all attempts to fix/bypass fsck. Jul 20, 2018 at 12:51
29

I experienced the same problem; though Mark's (top answer) solution didn't immediately work (since ctrl+alt+F2 etc. brings up a flickering TTYL which is nearly impossible to use), his suggested cause was correct, as it was a problem with the nvidia driver.

Also for beginners like me, here's the fool-proof step-by-step solution:

  1. Boot into safe mode (recovery mode). Enter this mode by holding the left shift key when the computer starts.

  2. in terminal, type:

    sudo apt-get purge nvidia*

    sudo ubuntu-drivers autoinstall #Make sure you have internet connection

Other solutions suggested elsewhere didn't work (e.g. installing boot-repair or sudo apt-get update)

(This worked on my dual booted computer (Windows 10 and Ubuntu 18.04)

my error message was /dev/nvme0n1p5: clean, nnn/nnn files, nnn/nnn blocks

5
  • 3
    I tried many things (including changing my display manager). sudo ubuntu-drivers autoinstall is what finally worked for me, thank you!
    – cyrusbehr
    Dec 31, 2019 at 1:15
  • 1
    It worked for me in normal mode also, not necessarily in safe mode. May 26, 2020 at 3:11
  • 4
    sudo ubuntu-drivers autoninstall gave me "No drivers found for installation" Oct 7, 2020 at 3:01
  • Watch out, I had the origin of my ubuntu software PPA pointed to my country and when I did sudo ubuntu-drivers autoinstall I lost ethernet and wifi drivers and probably others. The reason is supposed to be is that the repository of my country is outdated. The following answer helped me get them back: askubuntu.com/questions/1286738/…
    – kl0z
    May 23 at 17:14
  • 1
    I got stuck and waited for over half a hour so I tried this. It worked, saved my day!
    – Litchy
    Aug 11 at 7:28
21

I solved this by fixing the installation of my display manager (gdm3)

sudo apt install gdm3

Story behind this:

I was upgrading from Ubuntu 18 to 20. I have dual OS installed (Ubuntu 20 and Windows 10) on my Xiaomi laptop, no nvidia or AMD graphics card, Intel Core i5 8th gen.

  1. Log in to your terminal

    You can do this via reboot and choose recovery mode or press alt+f2 or ctrl+alt+f2 when the screen is stuck

  2. Connect to a network
    You can do this using

    iwconfig <your-wifi-adapter> essid <network-name> key <network-password> 
    
  3. Do basic recovery steps

    sudo apt update
    sudo apt clean
    sudo apt autoremove
    sudo apt update && sudo apt upgrade
    sudo dpkg --configure -a
    sudo apt install -f
    

    This should do the trick, but just to make sure, continue to the next step.

  4. Check display manager

    $ cat /etc/X11/default-display-manager
    /usr/sbin/gdm3
    

    Then systemctl status display-manager or /etc/init.d/gdm3 status make sure your display manager's status is active then sudo dpkg-reconfigure gdm3.

    If it shows

    /usr/sbin/dpkg-reconfigure: gconf2 is broken or not fully installed
    

    then there is your problem.

  5. Fix the broken package

    sudo apt install gdm3
    
1
  • This is the one that resolved the issue for me. Mine had been caused by removing python3-* packages, to upgrade from 3.8 to 3.9 on the system install. This unexpectedly uninstalled a bunch of other packages along with it, gdm3 among them. May 18 at 0:53
19

ctrl+alt+f2 or f3

  • login with your account
  • type sudo apt-get update (enter password when prompted)
  • type sudo apt-get install xserver-xorg-video-intel
  • reboot
2
  • or type journalctl and check what is going on there
    – swietyy
    Oct 16, 2018 at 16:56
  • 1
    But why does Ctrl+Alt+F2 help login? Jan 6 at 11:29
4

I faced same problem on Ubuntu 20.04; it was also because Nvidia driver. I just re-installed the driver and it started working properly.

sudo apt install --reinstall nvidia-settings
1
  • 1
    magically this helped me to get the UI back and I can login now. (20.04) Apr 12, 2021 at 14:03
4

I had the same problem. Before shutting down, the system noted: "low disk space".

I solved it by using an Ubuntu live disk (USB). I deleted files on the HDD to free space, then Ubuntu restarted as usual.

2
  • Fixed it for me, I switched to a terminal with ctrl+alt+F1 and deleted some big files Jun 30, 2021 at 17:06
  • Same for me, I did the same as Johannes and ran some commands to remove cache, to remove packages with sudo apt-get clean sudo apt-get autoclean sudo journalctl --vacuum-time=2d sudo apt-get autoremove --purge May 18 at 2:55
2
  1. Let's first check your file system for errors.

    To check the file system on your Ubuntu partition...

    • boot to the GRUB menu
    • choose Advanced Options
    • choose Recovery mode
    • choose Root access
    • at the # prompt, type sudo fsck -f /
    • repeat the fsck command if there were errors
    • type reboot

    If for some reason you can't do the above...

    • boot to a Ubuntu Live DVD/USB
    • start gparted and determine which /dev/sdaX is your Ubuntu partition
    • quit gparted
    • open a terminal window
    • type sudo fsck -f /dev/sdaX # replacing X with the number you found earlier
    • repeat the fsck command if there were errors
    • type reboot
  2. If step 1. doesn't fix your problem, then do this.

    • boot to the GRUB menu
    • choose Advanced Options
    • choose Recovery mode
    • choose Root access
    • at the # prompt, type:
    • sudo blkid
    • sudo cat /etc/fstab
    • edit your question to include the output from the two previous commands
    • type reboot
  3. pending fix here...

  4. If you dual boot with Windows, then do this in Windows.

    • open the Power control panel
    • click on change what the power buttons do
    • click on change options that are unavailable
    • uncheck fast start
    • close the Power control panel
    • open an administrative command prompt window
    • type powercfg /h off (turns off hibernation)
    • type chkdsk /f c:
    • approve that chkdsk runs at next boot time
    • reboot Windows
3
  • Run these steps and tell me the result, and I'll finish the answer with the final fix.
    – heynnema
    Feb 13, 2017 at 21:32
  • I have the same problem, it shows me the same /dev/sda1: clean..... message when I run the sudo fsck command. I type fsck and then reboot, however the problem still persists. I am not dual booting, I intend to have one OS that is Lubuntu on my 8 yr old netbook. Can you suggest what to do next Dec 1, 2017 at 16:03
  • @TransistorOverlord please start a new question. Provide as much detail as possible. Describe exactly what you've tried to fix the problem.
    – heynnema
    Dec 1, 2017 at 16:29
2

I had the same problem. Neither of the answers worked for me. I have an old laptop with an Atom processor without Nvidia graphics. Thus, I've adopted an alternative solution with nomodeset mode as follows:

  • In installation scene, press F6, use arrow keys to go down to nomodeset, and press Enter. An x will appear to its left. Then press Esc, and press Enter to "Try Ubuntu without installing" or "Install it".

[UPDATE]

I got into trouble with another laptop (ThinkPad T430) and I fixed that by disabling the discrete graphic card (Nvidia) in BIOS.

2

A mechanical issue with the hard drive can trigger an fsck execution on boot and that could be the cause of an error message of the following type:

dev/sdaX: clean, ******/******* files, *******/******** blocks

If the other solutions to this question don't work try swapping the hard drive with another replacement hard drive. It should also be noted that even low-priced budget SSDs have better performance than HDDs.

4
  • This message don't means a mechanical issue of any type. Please see: askubuntu.com/questions/987024/…
    – lestcape
    May 25 at 21:01
  • @lestcape Your comment is a false claim. From the accepted answer to your linked question (2nd to last paragraph): "there are other potential causes of fsck appearing on boot ( unclean unmount of the filesystem, cable or failing HDD sectors ,etc. )".
    – karel
    May 25 at 23:57
  • Well, i think you original answer is certainly right, because you said the opposite i said. I said: "This message don't means a mechanical issue of any type", and is true, because it only means that fsck was executed. But certainly you said the opposite: "A mechanical issue with the hard drive can cause an error message" and this could be rigth, because a mechanical issue can trigger an fsck execution on boot and that could be the cause of the message.
    – lestcape
    May 27 at 3:22
  • Sorry for misunderstood what you really said, you also get my upvote now.
    – lestcape
    May 27 at 6:10
1

I am not sure if this will work for everyone but I managed to fix this by removing every occurrence of nomodeset from /etc/default/grub file and then by executing sudo update-grub.

This was because nomodeset disables the use of any graphic driver. I disabled my nouveau drivers before installing nvidia ones.

Though this might not be the case with everyone.

1
  • Thanks, yes that make sense too. I have alienware 13 R-3, To install ubuntu I added nomodeset to enable ubuntu os to load. Once I installed nvidia driver, I was getting the above error. So on grub I pressed e for edit and removed the nomodeset and ctrl+x to rebboot. After that I got desktop all fine. Mar 11, 2019 at 13:31
1

The closest answer I found helpful to solve my problem was this one and I hope it will help you too

I just had a similar problem and I found problem was that the UUID for the EFI partition in /etc/fstab is not correct. I fixed it using the following:

Boot using live system USB/CD, open terminal, and check UUIDs for partitions root and EFI

lsblk -f

Use fdisk to know which is the EFI partition and make sure it's in the correct format (EFI system partition)

fdisk -l /dev/sdX

Mount the root partition /dev/sdXX into /mnt

mount /dev/sdXX /mnt 

then check the fstab file

cat /mnt/etc/fstab

If the UUID values are different, edit the value in the fstab file to match the correct UUID

use nano, gedit, vi, or whatever you want to edit and save fstab and reboot

that worked for me.

I believe the values changed because I installed Windows after installing Linux in my case.

1

If you have these symptoms:

  • Booting stops at "dev/sda1: clean..." or "/dev/nvme0n1p2: clean"
  • Not an Nvidia gpu (e.g. you have an AMD graphics card)
  • Default video driver installation (e.g. you did not install custom amd drivers yourself)
  • You are able to start a tty session using ctrl+alt+f2

Then there is a chance that GNOME Display Manager is not starting for some reason (eg due to a recent Ubuntu update).

To check:

  • Start a tty session: ctrl+alt+f2
  • Login to your account
  • Typing systemctl status display-manager gives an error or shows that the GNOME Display Manager is not both loaded and active.
  • As alternative to the previous step, you could also try looking in syslog file to see if gdm is starting up (eg cat /var/log/syslog | grep "Starting GNOME Display Manager")

If so, then type

  • sudo apt install --reinstall ubuntu-desktop to reinstall
  • reboot
2
  • If I am able to login via Ctrl+Alt+F2, then isn't it the solution? It is not too much hurdle to press those keys! Jan 11 at 12:19
  • @RawnakYazdani - You are right if your goal was to open access a terminal/tty on boot. But if your goal was to start the Ubuntu GUI on boot, then accessing tty session is only the first part of the solution.
    – Jaydin
    Jan 12 at 1:20
1

I reinstalled Nvidia drivers and the PC started working:

ctrl+alt+f2 or f3

  • Log in with your account

  • Run these commands:

     sudo add-apt-repository ppa:graphics-drivers/ppa
     sudo apt update 
     sudo apt install nvidia-settings
    
  • Reboot

(thanks to @Shahad and his solution at https://askubuntu.com/a/1218483/750140)

2
  • how do i connect my ubuntu 20.04 to internet in recovery mode ??
    – vatsalay
    Dec 3, 2020 at 8:15
  • But why does Ctrl+Alt+F2 help login? If it helps login, then isn't it the solution without requiring install or uninstall anything (yes, I understand I have to press the keys every time I boot, but it isn't much hurdle)? Jan 6 at 11:35
0

I had this problem with fresh install of 18.04.3 desktop on proxmox 6.1 Had to change to vmware compatible graphics for the VM before it would work..

0

You can avoid running fsck by booting into recovery mode and editing the file /etc/fstab to temporarily change the final 1 to 0 for the affected partition:

sudo nano /etc/fstab

Then reboot. If that gives a blank screen instead, reboot again, and press 'e' at the Grub menu. This time, omit the kernel parameters 'quiet splash' before resuming boot. You might get more helpful information to see where it is getting stuck - probably at the next step to do with gdm (or other login manager being used), or the system logging service. If you fail to rescue the existing installation, do a fresh installation using a wired internet connection so that it installs, makes the right settings, and updates correctly.

0

Very specific solution for me:

In recovery mode, disable automatic login for your user. I found it will make Ubuntu VM stuck at startup if you have Home folder encryption active and enable automatic login.

0

My issue was due to large size of Syslog file in /var/log/syslog. It has filled my HDD. So I have fixed it by the following steps.

  • boot with live USB
  • locate to /var/log/Syslog in your HDD
  • remove the file
  • reboot

For more info see this answer.

0

For AMD users:

  • Press ctrl+alt+f2

  • Log in to your account

  • Uninstall your AMD drivers by using either of these commands, depending on your drivers.

    amdgpu-pro-uninstall
    

    or

    amdgpu-uninstall
    
  • Do a reboot

  • After successfully logging in, reinstall your drivers.

Not the answer you're looking for? Browse other questions tagged or ask your own question.