Attempting to install tex-common on Ubuntu 16.04.

apt-get update
apt-get install tex-common

Fails, with /usr/sbin/update-updmap: line 235: bin/mkdir: No such file or directory

Reading package lists... Done                                                                                                                                                    
Building dependency tree                                                                                                                                                         
Reading state information... Done                                                                                                                                                
The following NEW packages will be installed:                                                                                                                                    
0 upgraded, 1 newly installed, 0 to remove and 44 not upgraded.                                                                                                                  
  Need to get 0 B/545 kB of archives.                                                                                                                                            
  After this operation, 851 kB of additional disk space will be used.                                                                                                            
  Selecting previously unselected package tex-common.                                                                                                                            
  (Reading database ... 214063 files and directories currently installed.)                                                                                                       
Preparing to unpack .../tex-common_6.04_all.deb ...                                                                                                                              
  Unpacking tex-common (6.04) ...                                                                                                                                                
  Processing triggers for man-db (2.7.5-1) ...                                                                                                                                   
  Setting up tex-common (6.04) ...                                                                                                                                               
  /usr/sbin/update-updmap: line 235: bin/mkdir: No such file or directory                                                                                                        
dpkg: error processing package tex-common (--configure):                                                                                                                         
subprocess installed post-installation script returned error exit status 1                                                                                                       
Errors were encountered while processing:                                                                                                                                        
E: Sub-process /usr/bin/dpkg returned an error code (1)

Any suggestions? Tried some of the suggestions mentioned here

  • Try to upgrade first. Run sudo apt update && sudo apt full-upgrade. Then (maybe after a reboot if needed) run sudo apt install --reinstall tex-common.
    – dgonzalez
    Feb 11, 2017 at 21:52
  • 1
    Still seeing the same errors, and now I'm also seeing errors related to keyboard-configuration, console-setup-linux, and console-setup, which seem to stem from bin/setupcon: 806: bin/setupcon: bin/../bin/ckbcomp: not found.
    – Udbhav
    Feb 12, 2017 at 16:29

1 Answer 1


Same situation for me, solved with these steps:

sudo apt remove --purge tex-common '^texlive'
sudo rm -rf /etc/texmf/
sudo apt install tex-common texlive-base texlive-latex-recommended \
                 texlive-latex-extra texlive-fonts-recommended latex-cjk-all

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.