0

First brief background. 2 SSD system, one with Windows, the 2nd with Ubuntu Linux. I had to do a complete BIOS reset recently when replacing my CPU water cooler. In Asus UEFI settings under Boot manager I at first can see my 2nd 1TB SSD with Linux installed so I do what I always do. Simply move to the top of the list, exit and restart. But my machine refuses to recognize it and always boots into windows. I also notice that the drive no longer has '[UEFI]' as part of its name.

According to my detailed notes I made when setting up my 'dual-boot' system these are the BIOS-UEFI settings that seemed to work

1-Disabled Fast Boot

2-Set CSM to UEFI only

3-Disabled Secure Boot

I made these changes and no difference except now my 2nd Linux drive doesn't even show up in my Boot manager list of drives! Before my water cooler fix and resetting the BIOS I had no issues and my Linux install was working perfectly. Anyone able to tell me what is happening? What should I attempt next?

  • 1
    Apparently you installed in Legacy/CSM mode. You probably canceled when prompted about UEFI. This is actually the only logical explanation because with the setting "UEFI only" the installer must have booted correctly in UEFI mode but then, at some point, a message about other system that may not be in UEFI mode appeared as usual asking to confirm. Can you remember what you did with it? – user589808 Feb 11 '17 at 19:34
  • Ran boot-repair. Seemed to fix issue – Bachalo Feb 12 '17 at 4:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.