0

I am on Ubuntu 16.04. I have installed Theano package for Python from the terminal interface as suggested in the official website. I have currently two versions of python (2.7 and 3.6) in my PC. Theano package has been inadverently installed to the 2.7, so when I try to import it on a python3.6 script file it says the ModuleNotFoundError: No module named 'theano'. I can understand the error. So I tried to install it to Python3.6 using the commands

sudo pip3 install Theano

But that didn't help. It showed me,

Requirement already satisfied (use --upgrade to upgrade): Theano in /usr/local/lib/python3.5/dist-packages Requirement already satisfied (use --upgrade to upgrade): numpy>=1.7.1 in /usr/lib/python3/dist-packages (from Theano) Requirement already satisfied (use --upgrade to upgrade): scipy>=0.11 in /usr/lib/python3/dist-packages (from Theano) Requirement already satisfied (use --upgrade to upgrade): six>=1.9.0 in /usr/lib/python3/dist-packages (from Theano)

So, I tried to upgrade the theano using:

sudo pip install --upgrade theano

That didn't help too. What can I do next?

  • Since the default system Python3 is 3.5 (16.04/16.10/17.04), how do you tell the system when you wish to use 3.6? – user535733 Feb 12 '17 at 1:33
  • I'm very new to Ubuntu. When I open python, it shows python3.6.0. Now, can you fix my problem please? – Bishwajit Purkaystha Feb 12 '17 at 1:35
  • sudo apt install python3-theano – user535733 Feb 12 '17 at 1:36
  • This gives me message: E: Unable to locate package python3-theano – Bishwajit Purkaystha Feb 12 '17 at 1:38
  • Oh, you are using 16.04 or earlier...or you have not enabled the 'universe' repo. Please edit your question to include your release of Ubuntu. – user535733 Feb 12 '17 at 1:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.