A bit like other questions on touchpads but with a twist, I think. The touchpad in this Lenovo IdeaPad Z360 had been acting up even when it ran Windows 7. I switched to an external USB optical mouse, but the thing often disappears, buttons stop working or pointer starts moving on its own.

xinput lists the following pointer devices:

⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ USB OPTICAL MOUSE                         id=10   [slave  pointer  (2)]
⎜   ↳ PS/2 Generic Mouse                        id=14   [slave  pointer  (2)]

"USB OPTICAL MOUSE" is external mouse. Is it possible that the two devices are fighting for control of the pointer and buttons? How can I disable "PS/2 Generic Mouse" and leave "USB OPTICAL MOUSE" reign unchallenged?

2 Answers 2


Go to system settings -> mouse and touch-pad.

Then Disable "turn off" touch-pad.

  • Thanks for the suggestion. It does not work in this case. The touchpad (probably broken) is not being detected correctly. It shows on the xinput output as "PS/2 Generic Mouse". Is it possible to disallow the driver behind it?
    – Stephen T.
    Feb 11, 2017 at 16:11

Blacklisting module psmouse solved all the erratic mouse behavior I was experiencing.

The broken touchpad was being identified by command xinput as PS/2 Generic Mouse instead of AlpsPS/2 ALPS DualPoint TouchPad. In the latter, the touchpad could have been disabled in system settings -> mouse & touchpad.

For instructions on how to blacklist a kernel module:


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .