1

Recently, I tried the method in Can I access Ubuntu from Windows remotely to connect from a Windows 10 laptop to an xfce session on a workstation running Xubuntu.

After logging off that machine, when I tried to log back onto my own physical machine (in person), I was locked out of the GUI session ! Strangely, the guest xsession account was working. I could log on to tty1, and set up another temporary admin account from the command line.

I was able to login to tty7 (graphical user session) using this newly created account. From there, I was able to go to user accounts settings, and verify that my original user account still exists with all admin privileges.

I solved the immediate problem by using the method in Login screen won't accept my password :

sudo rm .Xauthority
sudo reboot

But this leaves me with the question of what is going on in the first place. Can anybody shed light on what just happened ?

  • Did you end the session from the Windows machine? Is it possible that you are still logged in remotely? – Elder Geek Feb 10 '17 at 20:44
  • I could not end the remote session from windows. There was no panel, no terminal (even on right click 'open in terminal' , keyboard shortcuts for terminal didn't work either. It was an unproductive session from windows and I just closed and logged out. I have successfully repeated the problem and the solution twice, but I fail to understand what's going on in the first place – Krishna Feb 10 '17 at 20:50
  • If you are having difficulty closing a Remote Desktop session in Windows 10 you might find an answer to that problem here A bit of research will likely indicate that Windows is interpreting your keystrokes in an unexpected fashion (but that's likely off topic here as it's a Windows issue) – Elder Geek Feb 10 '17 at 21:00
  • This is not a duplicate of the other question. Comments from the OP indicate that although the problem was fixed, OP wants to know what happened. Why did login in from Win kill the .Xauthority file. (That said, I think it is a dupe, but I haven't found it yet.) – chaskes Feb 10 '17 at 21:05
  • This isn't really uncommon although I think it's off topic here. It's the result of failing to disconnect the session properly from Windows 10. Right click on the "start button". then hover over the sign off (?) option - should be second option from the bottom of the pop up menu - in the slide out window select Disconnect. – Elder Geek Feb 10 '17 at 21:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.