3

I have Ubuntu 16.04.1 fully updated.

Sometimes when in Webstorm the autocomplete popup is shown the monitor that has WebStorm flickers for a couple of seconds every time I press a key on the keyboard, making impossible to digit something. I have to change application and wait some minutes before I can use Webstorm again.

I haven't seen the problem with other programs

uname -a   
Linux *** 4.8.0-040800-generic #201610022031 SMP Mon Oct 3 00:32:57 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

Graphic card: Intel® Iris Pro Graphics 580 (Skylake GT4e)

  • Did you perform basic checks like - reinstalling the app ? Also do you have any graphic card ? – mac Feb 15 '17 at 17:32
  • 1
    whats your gpu? there are some gpu specific tweaks to prevent screen tearing. – Sirajus Salekin Feb 15 '17 at 17:58
  • @SirajusSalekin I have an Intel® Iris Pro Graphics 580 (Skylake GT4e). Also I noticed it happens more (but not only) on the monitor attached with a minidisplay port (I already tried to use another cable), and a bit less on the hdmi one – rpadovani Feb 17 '17 at 8:26
2
+100

Try these steps

sudo gedit /usr/share/X11/xorg.conf.d/20-intel-tearfree.conf

Paste

Section "Device"
  Identifier  "Intel Graphics"
  Driver      "intel"
  Option      "TearFree"     "true"
EndSection

Save, and reboot.

This fixed the screen flickering issue on a Sandy Bridge i5. It might help you too.

If you want, you can revert the changes whenever you want by typing

sudo rm /usr/share/X11/xorg.conf.d/20-intel-tearfree.conf
  • Nope, now it fails to login, the error is Feb 20 08:57:22 *** kernel: [ 38.995158] [drm:intel_dp_link_training_clock_recovery [i915]] *ERROR* too many voltage retries, give up Feb 20 08:57:22 *** kernel: [ 39.077060] [drm:intel_dp_link_training_clock_recovery [i915]] *ERROR* too many full retries, give up – rpadovani Feb 20 '17 at 8:02
  • You can remove the file anytime following the last command. But before you do so, try removing these two lines Option "AccelMethod" "sna" and Option "TripleBuffer" "true", if still does not work remove it using sudo rm /usr/share/X11/xorg.conf.d/20-intel-tearfree.conf. Finally, you can do a little research on Oibaf optimized. – Sirajus Salekin Feb 20 '17 at 12:16
  • This, and install linux-generic-hwe-16.04, improves a lot the situation! Thanks :) Please edit your answer to remove the two "wrong" options, I want to share the reply with some colleagues! – rpadovani Feb 20 '17 at 12:36
  • @rpadovani, I'm glad it worked. Updated the answer, thanks for your cooperation :) – Sirajus Salekin Feb 20 '17 at 12:39

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.