1

Today, I wanted to connect on my PMA panel to update a column of a database but found a weird message : It was saying that mbstring extension was missing although it was working fine until now. I looked a bit on Google and ended up installing new packages.

Then I faced lots of successive errors, Apache refusing to restart because of PHP5 and PHP7 in conflict, PMA that couldn't find mcrypt again, etc...

Now, things are working fine on Apache/2.4.7 and PHP7 BUT when I am trying to modify a column structure on PMA, it gives me this error :

Error in processing request | Error code 500 | Message Internal Server Error

I tried

sudo apt-get install php-mbstring php7.0-mbstring php-gettext
sudo service apache2 restart

as stated here (https://stackoverflow.com/questions/21699774/internal-server-error-http-error-500-after-installing-phpmyadmin-on-a-certain) but the error is still here.

Maybe it is related to a bad configuration during package installations, as it prompts at a moment :

Setting up phpmyadmin (4:4.0.10-1) ...
Configuration file '/etc/phpmyadmin/apache.conf'
 ==> Modified (by you or by a script) since installation.
 ==> Package distributor has shipped an updated version.
   What would you like to do about it ?  Your options are:
    Y or I  : install the package maintainer's version
    N or O  : keep your currently-installed version
      D     : show the differences between the versions
      Z     : start a shell to examine the situation
 The default action is to keep your current version.

I chose to keep my version but maybe there was an important change. I can't manage to have this question again to select "Y" instead of "N".

Any idea how to fix my problem and/or to fix my configuration ? I tried to look in my logs files /var/log/apache2/error.log, /var/log/mysql.err, /var/log/mysql/error.log but they are all empty. I am not sure where PMA errors are logged.

Thanks a lot !

EDIT I finally found some logs but the error is beyond my skills. Looks like there is something broken with my PMA installation ?

Uncaught Error: Call to undefined function Text_Plain_Preappend_getInfo() in /usr/share/phpmyadmin/libraries/transformations.lib.php:153

  • Is there Apache2's mod_security2 installed? – pa4080 Feb 10 '17 at 11:43
  • Hello @SpasSpasov ! I tried "sudo apt-get install mod_security2", it wasn't installed so I did it and restarted apache. Still, the error is still present on PMA. – R. N. Feb 10 '17 at 12:23
  • @SpasSpasov I just found some logs, edited my post. Thanks for helping ! – R. N. Feb 10 '17 at 12:29
  • 1
    My thought was, if there was mod_security2 installed, maybe it could throws this error, but in most cases it generates 403 errors. Whatever if you have decided to use mod_security2 OWASP ModSecurity Core Rule Set will make it really useful. – pa4080 Feb 10 '17 at 13:37
1

I managed to have a working installation of PhpMyAdmin by uninstalling the existing package and installing a "compatible version" from another ppa :

http://techfolkz.com/5/install-php-7-apache-2-mysql-56-phpmyadmin-45-on-ubuntu

Install Phpmyadmin

You should install php7 compatible version of phpmyadmin.Following commands are for installing phpmyadmin 4.5.3 on your server.You can check details here.

$ sudo add-apt-repository ppa:vincent-c/ppa
$ sudo apt-get update
$ sudo apt-get install phpmyadmin

Thanks for the help !

  • 1
    I just found that your old phpMyAdmin version (4:4.0.10-1) doesn't support PHP 7. Here is the reference. – pa4080 Feb 10 '17 at 13:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.