I've bought a new laptop DELL Inspiron i3 5th gen 3000 series. On my first login, even before restarting, I tried to apply updates and I got the error

locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory

It was so nagging to see this because I was using a Compaq laptop earlier and I had the same error, which I could never fix.

  • 1
    Did you install Ubuntu yourself or was it pre-installed? Anyway, can you please open a terminal window, run the locale command, and show us the complete output by editing your question. – Gunnar Hjalmarsson Feb 9 '17 at 23:48

Insert into /etc/default/locale:

LC_CTYPE="en_US.UTF-8"
LC_ALL="en_US.UTF-8"
LANG="en_US.UTF-8"

And regarding the missing locales, to generate them: sudo dpkg-reconfigure locales

  • And regarding the missing locales, to generate them: sudo dpkg-reconfigure locales – Galvani Mar 16 '17 at 8:55
  • 3
    Rather than commenting, edit your post to add the information. – UniversallyUniqueID Mar 16 '17 at 9:14
  • 1
    willdo next time – Galvani Mar 17 '17 at 11:15

This one worked for me.

sudo -i
locale
export LANGUAGE=en_US.UTF-8; export LANG=en_US.UTF-8; export LC_ALL=en_US.UTF-8; locale-gen en_US.UTF-8
dpkg-reconfigure locales
reboot

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.