48

I'm trying to edit the Sublime Text 3 user preferences (Preferences > Settings) to get it to show all formatting characters (including whitespace). I believe the line

"draw_white_space": "selection"

has to be changed to

"draw_white_space": "all"

but I cannot edit the JSON file. I'm running Ubuntu 16.04 LTS.

1
  • Are you changing user or default settings file? Feb 9, 2017 at 17:14

1 Answer 1

57

To get your settings picked by sublime you have to edit the Packages/User/Preferences.sublime-settings file.

To access go to:

preferences > settings

The files will open into a split form with default settings which are unalterable on the left of sublime text, and the editable user settings on the right. Now add your settings there:

{
    "color_scheme": "Packages/Color Scheme - Default/Monokai.tmTheme",
    "font_size": 10,
    "ignored_packages":
[
    "Vintage"
],
    "save_on_focus_lost": true,
    "draw_white_space": "all"
}

This will override the default settings version of this option.

3
  • 3
    Hmm, still doesn't draw/show newlines.
    – flow2k
    Jan 25, 2019 at 22:49
  • 2
    @flow2k - well whitespace and newline are two different things.
    – kta
    Apr 4, 2019 at 6:29
  • @kta, it depends upon the context. In many encodings, such as XML, and all derived markup, newlines ARE whitespace. w3.org/TR/xml/#NT-S Another example is \S in regex. In fact it's pretty rare for newlines NOT to be considered as whitespace.
    – Konchog
    Aug 29, 2019 at 10:32

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .