Re-edited to reflect latest findings:


My Atom D410 micro PC with Intel GMA3150 got a dual boot with Win7x64 and Ubuntu16.04. Ubuntu was installed second but does not fully boot. The PC has a single TFT Monitor, 1989x1020 resolution, connected via VGA and an USB keyboard and an USB mouse. Single 250GB HDD. Win7 runs stable without any graphics glitches for a few years on that machine.


Normal boot fails. Everything is fine until logging in on the desktop. Then I get a funny picture (see first image) for some 10-20sec, then the a black screen with mouse pointer only (second image). It flickers unevenly for about 30 secs. After that an empty standard background flickes in when I move the mouse the the screen edge or when I press keys. The system stays like that, no disk acitvity, no icons, no dock. I learned that Ubuntu has been installed to such systems sucessfully, so I hope there will be a sultion to it.

What I checked

  • I can use the console to login and work there. It does not change the main screen
  • I re-installed the driver xserver-xorg-video-intel, no change.
  • the graphics driver for the GMA3150 ist correctly installed (thanks CelticWarrior)
  • I can fully boot via Grub's Recovery option in FailsafeX mode. System is very slow (software graphics emulation) and generic screen is low res. During recovery boot it hangs at one place and I need o use Ctrl-C to make it continue

    Gtk-Message: gtkDialog mapped without a transient parent. This is discouraged

    /use/share/xdiagnose/failsaveXinit: line 177: return: zenity: numeric argument required

  • I installed Ubuntu twice, first time I upgraded to 16.10 and tried out the intel ungrade tool and other drivers suggested in various forum posts. I tried to change the screen resolution in failsafe with xrandr and cvt but got the error "Failed to get size of gamma for output default" where I did not find a solution in the forum.

  • For the second time I did a clean reinstall, formatting the partitions. I ran a disk check on the installation usb. I booted the live mode and tested the system. It ran fast. It showed the right Intel graphics driver and it recognized the screen and set its 1980x1020 resolution. Only thing I noted was that it seemed to have an "build-in display" beside the external screen. But there is not build-in display and the system only has one VGA connector. I disabled that build-in display and everything was fine. Maybe thats a hint to whats wrong here? Then I installed it from the live desktop.
  • here is the output from "lspci -vnn|grep VGA -A 12"

    00:02.0 VGA compatible controller [0300]: Intel Corporation Atom Processor D4xx/D5xx/N4xx/N5xx Integrated Graphics Controller [8086:a001] (prog-if 00 [VGA controller])
    Subsystem: Foxconn International, Inc. Atom Processor D4xx/D5xx/N4xx/N5xx Integrated Graphics Controller [105b:0d55]
    Flags: bus master, fast devsel, latency 0, IRQ 27
    Memory at fea80000 (32-bit, non-prefetchable) [size=512K]
    I/O ports at dc00 [size=8]
    Memory at d0000000 (32-bit, prefetchable) [size=256M]
    Memory at fe900000 (32-bit, non-prefetchable) [size=1M]
    Expansion ROM at <unassigned> [disabled]
    Capabilities: <access denied>
    Kernel driver in use: i915
    Kernel modules: i915

    00:1b.0 Audio device [0403]: Intel Corporation NM10/ICH7 Family High Definition Audio Controller [8086:27d8] (rev 02)

    • I found two posts about flickering with intel i915 drivers. They suggested to add "i915.enable_psr=0" to thedefault grub boot options. I did that but nothing changed. I also added "/etc/modeprob.d/i915.conf" with the line

      option i915 enable_rc6=6 enable_psr=2 enable_fbc_1 lvsd_downclock=1 semaphores=1

but there was no change, either.

  • Here the ouput from "sudo lshw -c display"

       description: VGA compatible controller
       product: Atom Processor D4xx/D5xx/N4xx/N5xx Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 00
       width: 32 bits
       clock: 33MHz
       capabilities: msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:27 memory:fea80000-feafffff ioport:dc00(size=8) memory:d0000000-dfffffff memory:fe900000-fe9fffff
  • output from "lsb_release -a".

    No ldb modules available
  • output from "xrandr". Shouldn't there be display outputs?

    can't open display

Image1: Desktop directly after login, no title no dock. Note the different overlaid bachground images above

Image2: black screen only with mouse pointer

Thanks in advance for any further suggestions.

PS: the boot log was too long to enter here


The problem persisted unter unity. When I installed the Xubuntu Desktop

sudo apt-get install tasksel
sudo tasksel

Then selecting Xubunut-Deskop & OK. I logged out of unity and logged in Xubuntu. The screen was still generic and the maximum resolution was still 1280x1024.

After reboot the system again the system booted correctly. I got a desktop title bar and icons. No visual artefacts. Note that I did not change the graphics driver. The Display settings tool now showed two displays: a laptop display and the external display. Default was the laptop display which was limited to 1280x1024. I disabled the laptop screen and got my external Monitor working with 1920x1080. Everything is fast and smooth. Finally!.

From what I saw, I guess the problem is somehow connected with this non-existing laptop monitor. The system seemed to have mixed the two in some ways producing this strange Multi background image and got totally out of sync, so it hang-up.

So if you run into a similar issue, the finding is: it could be the desktop manage that can not cope. The beauty is that an alternative desktop can be installed and tested in parallel and all application and data remain intact, there was no need for a full new installation.

Hope it helps someone.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.