1

I have got a laptop on ubuntu 16.04 and I can't configure the ethernet card ... I don't have wifi and ethernet connexion... I believe that it is a atheros e2600 but I am not sure.

when I type modinfo alx I have this :

    filename:       /lib/modules/4.4.0-31-generic/kernel/drivers/net/ethernet/atheros/alx/alx.ko
license:        GPL
description:    Qualcomm Atheros(R) AR816x/AR817x PCI-E Ethernet Network Driver
author:         Qualcomm Corporation, <nic-devel@qualcomm.com>
author:         Johannes Berg <johannes@sipsolutions.net>
srcversion:     25B6ABE36E6CB50C1A7E6DF
alias:          pci:v00001969d000010A0sv*sd*bc*sc*i*
alias:          pci:v00001969d000010A1sv*sd*bc*sc*i*
alias:          pci:v00001969d00001090sv*sd*bc*sc*i*
alias:          pci:v00001969d0000E0A1sv*sd*bc*sc*i*
alias:          pci:v00001969d0000E091sv*sd*bc*sc*i*
alias:          pci:v00001969d00001091sv*sd*bc*sc*i*
depends:        mdio
intree:         Y
vermagic:       4.4.0-31-generic SMP mod_unload modversions'

If I do lspci -nn I have this:

02:00.0 Network controller [0280]: Inter Corporation Device [8086:24fb] (rev 10)
03:00.0 Ethernet controller [0200]: Qualcomm Atheros Device [1969:e0b1] (rev 10)

I have download linux-firmware_1.127.22_all.deb and installed doing: sudo dpkg -i linux-firmware____.deb

I have tried this solution as weel: [Is there any way to install Atheros e2400 drivers?

without success either.

I added : enter code #define ALX_DEV_ID_E2600 0xe0b1 in reg.h and :

{ PCI_VDEVICE(ATTANSIC, ALX_DEV_ID_E2600),  .driver_data = ALX_DEV_QUIRK_MSI_INTX_DISABLE_BUG },

in main.c

but when I do

`make -C /lib/modules/$(uname -r)/build M=$(pwd) modules

(when I am in /ubuntu-xenial/drivers/net/ethernet/atheros/alx, is that where I should do it ?) I don't have any error. (make entering directory /usr/src/linux-headers-4.4.0-31-generic etc ... and then make leaving directory same one)

but when I do :

sudo make -C /lib/modules/$(uname -r)/build M=$(pwd) modules_install

I have an error: "no such file: bss_file.c:178 sign-file: certs/signing_key.pem no such file or directory".

any Idea ?

Regards,

5

You should be able to

sudo modprobe alx
echo '1969 e0b1' | sudo tee /sys/bus/pci/drivers/alx/new_id
Then the ethernet should function so you can install the 4.8 kernel with

sudo apt-get install linux-generic-hwe-16.04

Reboot

If uname -a shows that you have x86_64 kernel you can download the following package using a computer with internet access

http://archive.ubuntu.com/ubuntu/pool/main/l/linux-hwe/linux-image-4.8.0-41-generic_4.8.0-41.44~16.04.1_amd64.deb

http://archive.ubuntu.com/ubuntu/pool/main/l/linux-hwe/linux-image-extra-4.8.0-41-generic_4.8.0-41.44~16.04.1_amd64.deb

http://archive.ubuntu.com/ubuntu/pool/main/l/linux-meta-hwe/linux-image-generic-hwe-16.04_4.8.0.41.12_amd64.deb

http://archive.ubuntu.com/ubuntu/pool/main/l/linux-hwe/linux-headers-4.8.0-41_4.8.0-41.44~16.04.1_all.deb

http://archive.ubuntu.com/ubuntu/pool/main/l/linux-meta-hwe/linux-headers-generic-hwe-16.04_4.8.0.41.12_amd64.deb

http://archive.ubuntu.com/ubuntu/pool/main/l/linux-meta-hwe/linux-generic-hwe-16.04_4.8.0.41.12_amd64.deb

Copy them to the Desktop of the Ubuntu computer, then in terminal

cd Desktop

sudo dpkg -i *.deb

It should install the 4.8 kernel files, reboot when finished

  • I tried this solution without success. there was no error message, but I still don't have internet. – p.deman Mar 16 '17 at 13:27
  • 1
    Does lspci -nnk | grep -iA2 net show module in use alx? Does lshw -c net show ethernet as UNCLAIMED? – Jeremy31 Mar 16 '17 at 13:59
  • The first two lines worked for me on e2500 on Ubuntu 16.04 – standy Jun 4 '17 at 17:45
  • Worked for me, for Killer E2500, on Kubuntu 16.04.3 with 4.4.0-112-generic kernel. I could have upgraded the kernel (had wireless) but did not know which kernel would have support for Killer E2500... – kavadias Feb 23 '18 at 9:44
1

In the case of both your ethernet and wireless, there is no support in kernel version 4.4.0-xx. You are running 4.4.0-31-generic.

There is full support for both in kernel version 4.8.0-xx which is the default in Ubuntu 16.10. I suggest that you download and install 16.10 where both devices will work.

If you prefer another more difficult and cumbersome solution, please tell us and I will amend my answer.

  • Maybe install 4.8 to 16.04? – Pilot6 Feb 9 '17 at 14:54
  • 1
    Yes, indeed, @Pilot6, however, that requires downloading and transferring several packages on a USB and that's why I considered it cumbersome. – chili555 Feb 9 '17 at 14:56
  • what package should I download and transfer ? – p.deman Mar 16 '17 at 13:28
  • @p.deman Please start your own new question and include the result of: uname -r and also: lspci -nnk | grep 0200 -A2 Thanks. – chili555 Mar 16 '17 at 14:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.