Apologies for duplicating a question that is currently live but I'm desperate for the answer and as I'm new to AskUbuntu i don't yet have the reputation to add comments to the original question.
I am also trying to dual boot Ubuntu 16.04.01 onto a recently purchased Dell XPS 8910 tower but receive a fatal fail message when the installer reaches the grub install phase.

The computer is pre-installed with Windows 10 (UEFI) which is mounted on a 2 TB HDD with a RAID 0 link to a 32 GB SSD.

After many failed attempts to complete this task I have now disassociated the RAID disk from the master in Windows, thinking this might be the cause of the problem, converted SATA mode to AHCI and disabled the FastStartup function but still it fails on the boot grub install. I've also tried with SecureBoot disabled without any luck.

I'm using a live UEFI version of Ubuntu to perform the install (running off a USB) and have attempted using the INSTALL ALONGSIDE and SOMETHING ELSE options. Ive tried specifying many different locations for the boot loader installation but on the most recent attempt tried /dev/sdb since the Windows EFI partition is here.

The partitions on the two drives following a failed attempt are as below:

Disk /dev/sda: 29.8 GiB, 32017047552 bytes, 62533296 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: 892A53A1-3FCB-434D-9BFA-54B31909C

Device     Start    End Sectors  Size Type
/dev/sda1     34 262177  262144  128M Microsoft reserved

Disk /dev/sdb: 1.8 TiB, 2000398934016 bytes, 3907029168 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: gpt
Disk identifier: 42310B56-93E8-4769-A69B-F800C3921

Device          Start        End    Sectors   Size Type
/dev/sdb1        2048    1026047    1024000   500M EFI System
/dev/sdb2     1026048    1288191     262144   128M Microsoft reserved
/dev/sdb3     1288192 1959598079 1958309888 933.8G Microsoft basic data
/dev/sdb4  3878731776 3879653375     921600   450M Windows recovery environment
/dev/sdb5  3879653376 3907020799   27367424  13.1G Windows recovery environment
/dev/sdb6  1959598080 1969362943    9764864   4.7G Linux swap
/dev/sdb7  1969362944 1979127807    9764864   4.7G Linux filesystem
/dev/sdb8  1979127808 3878731775 1899603968 905.8G Linux filesystem

Any help would be much appreciated as after 4 days of trying I think I've exhausted guidance from previous posts.

  • Can you read this? I can't. – Pilot6 Feb 8 '17 at 21:02
  • Sorry Pilot 6 the cut and pastes from gparted have lost their format. are you able to read the rest of the text. First time I've posted a question so a little bit of an experiment. – IanUbuntu Feb 8 '17 at 21:05
  • Select the terminal output and press the {} button to format it properly. – Pilot6 Feb 8 '17 at 21:06
  • See how is it done? – Pilot6 Feb 8 '17 at 21:07
  • Should be legible now. Thanks Pilot6. – IanUbuntu Feb 8 '17 at 21:28

After lots of experimenting I think I've cracked it.

In summary:

  1. with the failed installed partitions still on the HDD boot back into windows and reinstate the RAID configuration originally supplied by Dell (need to turn SATA OPERATION to RAID On in the BIOS first)
  2. turn SecureBoot off in the BIOS
  3. boot back into the Ubuntu live disk and run boot-repair following the instructions in http://www.howtogeek.com/114884/how-to-repair-grub2-when-ubuntu-wont-boot. This should successfully install grub2 software without errors.
  4. Remembering to remove the live USB drive, reboot the computer. Grub2 then takes over and takes you to the Ubuntu log in screen.

To confirm Ubuntu is running with SATA set to RAID On and the disks still accelerated. I have disabled SecureBoot but will try turning this back on and see what happens (boot-repair requested it disabled to run).

I had tried running boot-repair with the RAID disks disassociated and the BIOS set to AHCI but this failed with the warning that the EFI partition was locked. This was resolved as described in points 1-3.

I haven't tested it but I'm assuming you should be able to install Ubuntu from the live disk without disassociating the RAID disks in Windows. The steps using boot-repair will still probably be required.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.