1

I tried booting into Ubuntu (I have dual boot of Windows 10 and Ubuntu) and faced with the following error message:

usb 1-1.4: device descriptor read/64, error -32
/dev/sda5: contains a file system with errors, check forced.
/dev/sda5: 433585/1319328 files (0.3% non-contiguous), 3069030/5290240 blocks fsck exited with status code 1
Welcome to emergency mode! After logging it type "journalctl -xb" to view system logs, "systemctl reboot" to reboot, "systemctl default" or ^D to try again to boot into default mode. 
Press enter for maintenance
(Or press Control-D to continue)
root@localhost:~#

What I've tried:

  • I've tried to follow the instructions provided here but couldn't resolve the issue (note: I replaced /dev/sdb1 with /dev/sda5) and I get the following message after executing the command fsck -y /dev/sda5 but after reboot I still had the same error:

fsck from utill-linux 2.27.1

e2fsck 1.42.13 (17-May-2015)

/dev/sda5: clean, 433587/1319328 files, 3069032/5290240 blocks

  • I've tried rebooting and Ctrl-D, but nothing was resolved

Any help would be very much appreciated; I really hope I can fix this issue soon because I really need to use my laptop.

0

So the cause of error is not completely clear. Some believe that "most probably it’s a result of hardware failure rather than a driver or kernel bug." And this article suggested that "unplugging all USB devices from PC, turnning power off, and waiting a minute or two would do the trick." However,. I didn't have any USB devices plugged into my laptop, so this solution was not helpful, even though it apparently has solved the issue for many other people.

What actually solved the issue for me was executing the following command as a root user:

root@localhost~# fsck -y /dev/sda1
root@localhost~# fsck -y /dev/sda2
root@localhost~# fsck -y /dev/sda3
root@localhost~# fsck -y /dev/sda4
root@localhost~# fsck -y /dev/sda5
root@localhost~# fsck -y /dev/sda6
root@localhost~# fsck -y /dev/sda7

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.