2

I'm brand new to linux and I am currently running Ubuntu 16.10.

My problem is that my wifi just will not stay connected at all. When started, it will stay connected for about about 3 minutes MAXIMUM before the internet just completely stops working.

What's weird is that up top I can still see that its connected to the wifi, but the internet just stops working completely. If i use an ethernet cable, I don't have this problem at all; but i need to use wifi because my router is way too far away from my pc.

So far the only thing that fixes it is disconnecting from the network, and then reconnecting and itll work again for about anywhere between 1-3 minutes before it just suddenly stops again.

IMPORTANT SIDE NOTE : I'm dual booted with windows 10, and on windows I absolutely do not have this problem whatsoever, the wifi works just fine. Any help is greatly appreciated

wireless card details:  description: Wireless interface
       product: RTL8821AE 802.11ac PCIe Wireless Network Adapter
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:01:00.0
       logical name: wlp1s0
       version: 00
       serial: b0:c0:90:1b:c6:dd
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=rtl8821ae driverversion=4.8.0-37-generic firmware=N/A ip=192.168.0.7 latency=0 link=yes multicast=yes wireless=IEEE 802.11
  • I have a simular issue with a HP laptop that I have. What is the make and model of the machine that you are using? After some investigation it appears that my issue is more hardware related and there are a few drivers to install from the hp help forum. However, if yours is working on Windows OK that would point more to Ubuntu. – Phil UK Feb 8 '17 at 21:41
2

It sounds like a wifi power management issue, we can disable it with a module parameter

echo "options rtl8821ae ips=N" | sudo tee /etc/modprobe.d/rtl8821ae.conf

Reboot and see if it has improved.

If you are using Network Manager, we may also have to do

sudo sed -i 's/wifi.powersave = 3/wifi.powersave = 2/' /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf

Then reboot

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.