0

Issue

I configured fstab to mount my sd card as /backup automatically at startup. But everytime fstab doesn't find the sdcard, it gets stuck at the xubuntu 14.04 bootscreen waiting for the user to press A (continue without sdcard) or M (retry mounting).

fstab to mount sd card

/dev/mmcblk0p1 /backup vfat comment=x-gvfs-show,users,uid=1000,auto 0 0

Needs

Is there a possibility to skip this error message screen even if sdcard is not found/cannot be mounted, so that the user can startup xubuntu without any holdups? Thanks!

2

According to man fstab, you can add the mount option nofail. If I recall correct this works for that situation (I did it once, years ago).

  • hi there thanks for your reply, but somehow nofail doesn't work in 14.04 Xunbuntu. Instead I tried with nobootwait which worked. – Chiggiddi Feb 10 '17 at 13:53
1

Solution

since Xubuntu 14.04 doesn't react to nofail, there is a workaround with nobootwait. See bug report: https://bugs.launchpad.net/ubuntu/+source/mountall/+bug/610869

Updated example:

/dev/mmcblk0p1 /backup vfat comment=x-gvfs-show,users,uid=1000,nofail,nobootwait,auto 0 0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.