9

I have a dell XPS 15 laptop (GTX 960M) with Ubuntu 16.04 installed which is connected to two dell monitors.

After installing the nvidia drivers via Sofware & Updates (I am using NVIDIA binary drivers version 378.09 from nvidia-378) I proceed to "NVIDIA X Server Settings" to configure which of my monitors will be the primary one.

Sadly, I am unable to configure the primary monitor and the monitors layout. All screens in "X Server Display Configuration" are shaded and with the following note:

"PRIME Displays cannot be controlled by nvidia-settings and must be configured by an external RandR capable tool. The display is shown in the layout window for information purposes only". (see NVIDIA X Server Setting screen-shot)

I am not sure if this is due to the nvidia drivers I installed or another issue alltogether. I checked on nvidia-drivers site and for my graphics card (GTX 960M) there are no drivers for a 64 bit linux OS, only 32.

If anybody has a solution such that I can configure my screens, choose primary display and which is to the left and right, I would greatly appreciate the help.

4

Here is my recent revised solution on Ubuntu 18.04 to get screen synchronization on my External Monitor to ...

... STOP SCREEN TEARING!! with Nvidia Drivers in use

04/12/18 ∘ PRIME Synchronization on Optimus

To check:

sudo cat /sys/module/nvidia_drm/parameters/modeset

It Should say "y" for modeset=1, for your Monitor ex. HDMI-1-1, or eDP-1-1

To get PRIME Synchronization on Optimus when it says "N" for NO , create a new file in /etc/modprobe.d/nvidia-drm-nomodeset.conf

sudo gedit /etc/modprobe.d/nvidia-drm-nomodeset.conf

And make sure the following line is present;

options nvidia-drm modeset=1

And after a Reboot or Update Intramfs Here is the Update Intramfs code sudo update-initramfs -u

Now sudo cat /sys/module/nvidia_drm/parameters/modeset, will give a Y for Yes, and screen tearing is greatly reduced!

  • Great :) it works for Lenovo legion y720 – madzohan May 29 '18 at 5:25
  • Fantastic! I had been struggling for years with my Lenovo Y700 and this finally solved it on Pop!_OS 18.04. – sawablo Nov 5 '18 at 16:20
  • unfortunately for me it disables one of 2 external monitors (Ubuntu 18.04, dell precision 7520, 2 external monitors + laptop's monitor) – rgrebski Nov 28 '18 at 8:20
  • This tecnique of Prime Synchronization (putting options nvidia-drm modeset=1 inside a config file in modprobe.d) completely broke my system. At restart, kubuntu restarted into a black screen. After 3 hours the solution was to remove a corrupted xorg.conf file: mv /etc/X11/xorg.conf /etc/X11/xorg.conf.bak – rtrtrt Dec 7 '18 at 0:00
2

Use the native Displays settings panel:

Displays Settings

You can open this by going to System Settings and selecting Displays, or by just searching for Displays in the Dash.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.