20

Installing Tor bundle from Ubuntu Software center on 16.04.

I have searched for similar cases. But only found one post, that was marked as a duplicate... But, it doesn't tell you where the duplicate is OR what the title of the duplicate is. And, I couldn't find it anywhere.

When starting the Tor Browser from the system menu (I am currently using the MATE distro of 16.04) It starts a "download" of the Tor browser. (Which is already installed from the USC...?) And, once it is finished with that, about five minutes later, I get "SIGNATURE VERIFICATION FAILED - You might be under attack, or there might just be a networking problem."

OK, So, I deactivate UFW, and the firewall on my router... then click "start" to retry the download... Now, with NO firewall active, another five minutes later, I receive the same error.

The purpose for using TOR is that I want to use an application called RetroShare with family and friends on other continents. The app requires a TOR "secrethidden space" and it's X.onion address in order to work. But, I cannot for the life of me figure out what the problem is with this TOR Browser. Documentation is (intentionally?) cryptic. It says to "do XYZ" with no hint whatsoever HOW to do XYZ or what it even means to "do XYZ".

Anyway, I have tried to follow reasonable methodology as far as I am able. But, the failures provide no clue as to what steps need to be taken to avoid the error happening over and over again. If it isn't firewall, I have no clue how to proceed.

  • 1
    try this – George Udosen Feb 8 '17 at 8:12
  • Not seeing anything new there. The "tor bundle" has already been installed. This error is produced by actually attempting to RUN the tor browser... I'm not at all clear on why it is attempting to download the tor browser again... The docs are very unclear as to what is supposed to happen. – Orian Feb 8 '17 at 9:14
  • What does which tor give you ? – George Udosen Feb 8 '17 at 9:20
  • 1
    @George: Apologies... You were correct. I uninstalled (purged) and reinstalled following the instructions on the TorProjects site (instead of using the Ubuntu Software Center) as you originally suggested. The Browser now connects. But, I seem no closer to my goal. where is Vidalia? And, how does one go about setting up this "Hidden Service" that I need? Once again, I though it would be obvious once Tor was installed. – Orian Feb 8 '17 at 10:23
  • 1
    OK... I have read my eyes raw. Finally found all the pieces to creating and using a hidden service with Tor. Didn't expect that I would need to install a http server. But, there it is. Thanks for helping to get Tor Browser running. – Orian Feb 8 '17 at 13:42
34

This is due to an outdated key for verifying the torbrowser-launcher download. Try:

gpg --homedir "$HOME/.local/share/torbrowser/gnupg_homedir/" --refresh-keys --keyserver pgp.mit.edu

This worked fine in my case and I was able to successfully launch the tor browser.

Duplicate: https://unix.stackexchange.com/questions/341513/torbrowser-signature-verification-fails-a-glitch-or-an-attack/341519

  • 2
    This should be the accepted answer. – berkes Oct 5 '17 at 8:05
  • 2
    This solution failed for me, reporting 'unknown pubkey algorithm'. – Jon Carter Dec 21 '17 at 9:16
  • I ended up using the browser bundle downloaded directly from the Tor website – Jon Carter Dec 21 '17 at 9:38
  • 1
    In 16.04 this gives me gpg: no valid OpenPGP data found. gpg: Total number processed: 0 gpg: keyserver communications error: keyserver helper general error gpg: keyserver communications error: unknown pubkey algorithm gpg: keyserver refresh failed: unknown pubkey algorithm – Lembik Apr 9 '18 at 12:43
  • For me it is gpg: keyserver refresh failed: No data – takeshi Aug 14 at 8:51
6

It's fixed in the latest version of torbrowser-launcher. Add the author's PPA to get the update:

sudo add-apt-repository ppa:micahflee/ppa
  • This worked after I tried a half dozen other attempted solutions. The answer deserves more up votes. – darkhipo Aug 13 at 6:18
4

Try the following:

gpg --homedir "$HOME/.local/share/torbrowser/gnupg_homedir" --refresh-keys --keyserver keyserver.ubuntu.com

It worked for me on ubuntu 16.04

0

Debian 9 parrot OS has the same problem. It was fixed for me by completely purging tor and installing the tor browser bundle from torproject.org. It's a pretty straightforward process. Download the matching version for your system architecture. Extract the file to wherever. Open the extracted folder and you will find a setup application labeled something like setup-tor-browser... Launch and follow prompts. Also please note that your time needs to be correct, and you cannot run tor as root unless you edit the start-tor-browser file to allow for it. Note that you can still use proxychains with this configuration.

protected by Community Aug 31 at 7:07

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.