1

I receive all packets directed to my system. The problem is never getting any packets of other systems to other systems that are connected to the same network.

I am working with Ubuntu and using Wireshark to capture wireless traffic. I enable the monitor mode.

naveen@naveen-Inspiron-3542:~$ sudo ifconfig wlp6s0 down
[sudo] password for naveen: 
naveen@naveen-Inspiron-3542:~$ sudo iwconfig wlp6s0 mode monitor
naveen@naveen-Inspiron-3542:~$ sudo ifconfig wlp6s0 up
naveen@naveen-Inspiron-3542:~$ iwconfig
enp7s0    no wireless extensions.

lo        no wireless extensions.

wlp6s0    IEEE 802.11bgn  Mode:Monitor  Frequency:2.462 GHz  Tx-Power=15 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:off

enable promisc mode

 sudo ifconfig wlp6s0 promisc
[sudo] password for naveen: 
naveen@naveen-Inspiron-3542:~$ netstat -i
Kernel Interface table
Iface   MTU Met   RX-OK RX-ERR RX-DRP RX-OVR    TX-OK TX-ERR TX-DRP TX-OVR Flg
enp7s0     1500 0         0      0      0 0             0      0      0      0 BMU
lo        65536 0     13575      0      0 0         13575      0      0      0 LRU
wlp6s0     1492 0    334227      0    199 0        235922      0      0      0 BMPRU

Then I open wireshark. Then I enter the wifi password:
edit > preference > IEEE 802.11 > edit decryption keys > key-type="wpa-pwd" and key="wifipassword"

Enable the promiscuous mode.

    Capture > Options > Enable promiscuous mode on all interfaces.

I am not able to see my teammates IP addresses.

What should I do?

My ip address:

 192.168.1.214

root@naveen-Inspiron-3542:/home/naveen# airmon-ng start wlp6s0
Found 5 processes that could cause trouble.
If airodump-ng, aireplay-ng or airtun-ng stops working after
a short period of time, you may want to kill (some of) them!
-e 
PID Name
924 avahi-daemon
971 avahi-daemon
1016    NetworkManager
1307    wpa_supplicant
25470   dhclient
Process with PID 25470 (dhclient) is running on interface wlp6s0


Interface   Chipset     Driver

wlp6s0      Atheros     ath9k - [phy0]
                (monitor mode enabled on mon0)

closed as off-topic by waltinator, karel, Fabby, user117103, David Foerster Feb 9 '17 at 11:20

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This is not about Ubuntu. Questions about other Linux distributions can be asked on Unix & Linux, those about Windows on Super User, those about Apple products on Ask Different and generic programming questions on Stack Overflow." – waltinator, karel, Fabby, guntbert, David Foerster
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 4
    Is "the same network" connected to a switch? If so, the switch must be configured to send all packets to your port. AFAIK, Normally, switches keep track of which MAC address is connected to which port, and only send packets for that MAC address to that port. Not all switches can be configured to do this. Not a Ubuntu problem. – waltinator Feb 8 '17 at 5:11
  • @waltinator The network in connected to a router. And there were 5 pc connected in same network. I can capture only my pc ip address and can't able to capture other pc's ip address on the same network . – XtremeTester Feb 8 '17 at 5:54
  • @muru Can you help me ? Still I'm not getting the ipadress of the some network – XtremeTester Feb 8 '17 at 7:14
  • You need to configure the shared switch to forward all packages to the port connected to your computer. How to do that (if the switch supports it at all) is unrelated to Ubuntu and therefore off topic here. – David Foerster Feb 9 '17 at 11:19