0

I am using a Samsung NP-X420 with Ubuntu 14.04.5 LTS, Trusty Tahr, 32-bit. The screen is so bright that it is irritating my eyes. When I press the brightness adjustment keys on the keyboard (Fn+down arrow), I can see the brightness window appear on the top right corner. The brightness bar is also moving left and right, indicating that the brightness is changing, but in reality, nothing happens. The brightness remains harsh.

I am aware that this question might be labeled as duplicate of this question: How to adjust screen brightness in Ubuntu 14.04 (Trusty Tahr)? The issue is: I have tried the solution given by Serg but to no avail. Everything went good until the last step, where he opened the nano editor. When I put the value "0" in there, the brightness didn't change. It remained this harsh light.

Given that the first method didn't work for me, I tried the method given by this article: https://itsfoss.com/fix-brightness-ubuntu-1310/. When I used this command ls /sys/class/backlight/ in the terminal, I got this output: acpi_video0 intel_backlight. So far so good. Then I gave in this command: sudo touch /usr/share/X11/xorg.conf.d/20-intel.conf and it asked me for my password, which I successfully entered. So still nothing wrong there. But the issue lies with the following command: sudo gedit /usr/share/X11/xorg.conf.d/20-intel.conf. When I put that in the terminal, this is what I get: sudo: gedit: command not found.

Am I doing something wrong in any of the methods listed above? Is there another way to adjust the brightness? Do I need to install drivers? If yes, then please tell me which ones. I am not so familiar with Linux or in general, computer stuff. Can anyone please help? My eyes are burning.

Thanks in advance!

1

The error merely says that you don't have GEdit installed. Use some other editor instead.

If you already used nano, you can use it for this, too:

sudo nano /usr/share/X11/xorg.conf.d
  • Thank you for your answer. I gave in your command and I got this wondow, in which I typed the following (as suggested by the link I gave in my post): imgur.com/a/c5xOu. I needed to save the file, and I don't see how to do that. So this is what I did: I pressed Ctrl+x to exit. Then it asked me to save changes, I pressed y (for yes). And then it asked me to give a name to the file. I called it "brightness". Then I hit Enter and the window closed. I logged out and back in, but nothing changed. My brightness is still harsh and I still can't modify it. Do you perhaps know what I did wrong? – I. Wewib Feb 8 '17 at 17:41
  • Typing it into the editor wasn't necessary. You could've simply copied and pasted it. Note, however, that you have to add the shift key to the normal widespread shortcuts (like copying, pasting, opening a new window, opening a new tab, closing a tab, etc.) because without the shift key, they are control sequences. So pasting is Ctrl + Shift + V instead of Ctrl + V. Alternatively, you can right-click and choose Paste. – UTF-8 Feb 8 '17 at 22:11
  • Now to your problem. The command edits a specific file. You want to make your changes in this file permanent by saving it. What you did, however, was to create a new file consisting of the file you were supposed to edit and your changes to it. You called it "brightness". What you need to do after exiting and confirming that you want to save your changes is to simply hit enter. The path of the file you opened is already entered by default and hitting enter will confirm that the contents of the editor are saved to this path. – UTF-8 Feb 8 '17 at 22:14
  • Once again, thank you for your time and help @UTF-8. When I hit enter after saving, I get this message [ Cancelled ]. When I log out and back in, I still can't adjust the brightness with the keyboard keys. Here are screenshots of all the steps I went through, with description underneath every picture: imgur.com/a/FH26S – I. Wewib Feb 9 '17 at 19:44
  • Your mistake is that you didn't enter the last part of the path /usr/share/X11/xorg.conf.d/20-intel.conf when calling nano. You only entered the part without the name of the file: /usr/share/X11/xorg.conf.d/20-intel.conf. That's why you get the warning that the file you attempted to open doesn't exit. nano started anyways with no file opened. That's why it didn't automatically propose the name of the file you edited when you wanted to save: Because you didn't edit a file. You merely wrote text in a text editor. You can't save a file with an empty name, that's why it said "Cancelled". – UTF-8 Feb 9 '17 at 19:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.