2

I am totally new to Linux and programming. I want to learn Python with the Visual Studio Code text editor, but I'm having trouble to download and install it.

I downloaded VSC from the official website, but I received an error message from the package installer when I tried to install it: Wrong architecture 'amd64'.

The second method I tried was running this command in a terminal: sudo dpkg -i vscode-amd64.deb (I saw it on a YouTube video), but I received this error:

dpkg: error processing archive vscode-amd64.deb (--install):
 cannot access archive: No such file or directory
Errors were encountered while processing:
 vscode-amd64.deb

Can someone please help me? My Linux version is Ubuntu 14.04.5 LTS, Trusty Tahr.

Thanks in advance!

  • Please don't post screenshots of text. Copy the text here and apply code formatting. – muru Feb 7 '17 at 16:32
  • Thank you for the feedback @muru. I will keep that in mind. – I. Wewib Feb 7 '17 at 21:23
  • Thank you very much @cl-netbox for editing my post to make it more readable. You made me learn valuable lessons. I will definitely focus on makining future posts more readable. – I. Wewib Feb 7 '17 at 21:27
  • @I.Wewib I would rather you start with this post – muru Feb 7 '17 at 22:42
3

You seem to have downloaded the wrong packages and as you didn't provide further details about the architecture of the Ubuntu system you use, here are the correct download links ->

Open a terminal in the directory where you have saved the downloaded file (or change to it).

On 64-bit Ubuntu editions execute this command :

sudo dpkg -i code_1.9.0-1486023356_amd64.deb  
sudo apt-get install -f

On 32-bit Ubuntu editions execute this command :

sudo dpkg -i code_1.9.0-1486024310_i386.deb  
sudo apt-get install -f

More information -> Running VS Code on Linux

Note : The direct download links and the file names are valid as of writing this answer today.
They will change with every new release, hence check the Download Visual Studio Code site.
This additional information is just meant to be for other users reading this post in the future.

  • Thank you very much for the help. It solved my problem. I indeed have a 32-bit Ubuntu edition. I also want to thank you for editing my post to make it more readable. This made me learn valuable lessons, which I will keep in mind for future posts. – I. Wewib Feb 7 '17 at 21:38
  • Can I bother you with one more thing @cl-netbox? Do you perhaps know why I'm not getting any syntax highlighting and how I can fix it? Here is a screenshot of VSC: imgur.com/a/nzFOj – I. Wewib Feb 8 '17 at 15:51
  • I know what the problem was. I didn't get syntax highlighting because the file I was opening was a text document. When I gave it the extension ".py", I did get the syntax highlighting. How stupid of me. – I. Wewib Feb 8 '17 at 16:16
0

You need to download the 32-bit version to match your computer. It can be found at https://code.visualstudio.com/#linux32-downloads-stable

  • You are right heynnema. My Ubuntu is indeed 32-bit. Thank you very much for your answer. I really appreciate it. I do have to give the vote to @cl-netbox though since his/her answer was more helpful. – I. Wewib Feb 7 '17 at 21:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.