3

I have dual booted with XP and Ubuntu 11.04. Later I formatted Ubuntu partition with 11.10 now I have three drives one for XP other for UBUNTU and other for data when I log in into UBUNTU I am unable to create or delete the all files in the other two drives (XP drive and data drive).

Is there any way to change permissions to the entire drive?

I am unable to change permission by GUI (properties option).

1 Answer 1

6

The method you use to set permissions varies with the file system.

For linux permissions it is chown/chmod , but I am guessing you are asking about ntfs.

For ntfs, edit the appropriate line in /etc/fstab add in the permissions option

UUID=12102C02102CEB83 /media/windows ntfs-3g auto,users,permissions 0 0

Change your UUID to your NTFS partition , you can list it with

sudo blkid

You then re-mount the partition and use chown and chmod

sudo chown your_user:your_user /media/windows
sudo chmod 770 /media/windows

If you want a graphical tool, use PySDM

sudo apt-get install pysdm

PySDM

See also Ubuntu Wiki File permissions

12
  • is it possible to do it by using gparted
    – VENKI
    Commented Dec 15, 2011 at 20:58
  • no, gparted is a graphical front end for managing partitions - making them, resizing them, etc, but not for managing files or file permissions.
    – Panther
    Commented Dec 15, 2011 at 21:01
  • i am unable to unmark the option mount the drive with read-only mode little help please how to change the drive from READ MODE to CREATE OR DELETE mode
    – VENKI
    Commented Dec 15, 2011 at 21:33
  • in my permission menu i have both owner and the group as root
    – VENKI
    Commented Dec 15, 2011 at 21:35
  • What "permission menu" ? Did you make the change in fstab ? psydm ?
    – Panther
    Commented Dec 15, 2011 at 22:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .