As many others, I am having difficulty getting my bluetooth to work in Ubuntu 16.04 on my Dell XPS13.

What I've tried so far:

  1. Set Autoenable=true (https://askubuntu.com/a/808114/645176)
  2. Install some firmware (https://askubuntu.com/a/613622/645176)
  3. Install Bluez and try to use that manager

After these steps somehow I figured to not make the bluetooth device even start now...

Info on my device:

Rfkill list

0: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
1: brcmwl-0: Wireless LAN
    Soft blocked: no
    Hard blocked: no

Dmesg grep blue

[  123.321631] Bluetooth: Core ver 2.21
[  123.321649] Bluetooth: HCI device and connection manager 
[  123.321653] Bluetooth: HCI socket layer initialized
[  123.321655] Bluetooth: L2CAP socket layer initialized
[  123.321663] Bluetooth: SCO socket layer initialized

lspci -knn | grep Net -A2; lsusb

02:00.0 Network controller [0280]: Broadcom Corporation BCM4352 802.11ac Wireless Network Adapter [14e4:43b1] (rev 03)
    Subsystem: Dell BCM4352 802.11ac Wireless Network Adapter [1028:0019]
    Kernel driver in use: wl
    Kernel modules: bcma, wl
Bus 001 Device 002: ID 8087:8001 Intel Corp. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 002 Device 007: ID 0bda:5682 Realtek Semiconductor Corp. 
Bus 002 Device 006: ID 04f3:20d0 Elan Microelectronics Corp. 
Bus 002 Device 008: ID 413c:3016 Dell Computer Corp. Optical 5-Button Wheel Mouse
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Any tips? Cheers.

2 Answers 2


I was troubleshooting this for a while on my Dell XPS 13 with Ubuntu 16.04, and will tell you the shortened version of some answers in these steps that worked for me. Bluetooth Broadcom 43142 isn't working

List your usb devices


shows this on my laptop for Bluetooth

Bus 002 Device 002: ID 0a5c:216f Broadcom Corp. BCM20702A0 Bluetooth

Go to the following Github page and download the already converted driver that matches your ID: https://github.com/winterheart/broadcom-bt-firmware/tree/master/brcm (mine was BCM20702A1-0a5c-216f.hcd) Click on the file name, then click the Download button.

Copy your file to /lib/firmware/brcm, for example:

sudo cp BCM20702A1-0a5c-216f.hcd /lib/firmware/brcm


That is the simplest method for what it took to get my bluetooth working correctly on Dell XPS 13, headsets and other devices all were able to connect after that.

  • 2
    Don't know why this doesn't have more upvotes. This is 100% the correct way of doing it and it is fast too. Last time I had to do this, it took me hours. This took two minutes.
    – Astrid
    Aug 1, 2017 at 11:30
  • 2
    Thank you so much! You saved my day. This answer should be accepted as a solution.
    – Serge P
    Nov 26, 2017 at 11:29
  • 4
    This saved my day! Oh wait, it's midnight already.. Feb 21, 2018 at 22:58
  • 2
    Yeeeeees! However I couldn't find the driver for XPS13 2015 on mentioned github repository. Found it here though! github.com/hg8/bluetooth-firmware-XPS13-9343
    – ngasull
    Mar 4, 2018 at 18:51
  • 3
    This combined with Blunt's answer below saved it for me on Manjaro linux with Dell XPS 13 9350 Jul 20, 2019 at 21:11

Great advice! Thank you. Let me just provide a detail tweak that others may also find useful. In my case I was having problems (stutter) in playing sound through a bluetooth JBL Go from my XPS 13 9350 on Ubuntu 16.04.

After the operations indicated by phandolin the problem remained. The lsusb command provided this information:

Bus 001 Device 002: ID 0a5c:6412 Broadcom Corp.

However the command

dmesg | grep Blue

showed an error

[ 2.741102] Bluetooth: hci0: BCM: Patch brcm/BCM-0a5c-6412.hcd not found

I noticed that the name of the downloaded file needed to be changed. Therefore (in my case) I just renamed the downloaded file from




reboot et voilá! No more error in dmesg. Just to be sure I removed the paired device, paired it again and it's working ever since.

  • I love you so much Oct 6, 2017 at 8:20
  • I had been trying to get BT working for so long, this finally worked. Thank you!!!
    – Fiver
    Feb 11, 2018 at 18:15

Not the answer you're looking for? Browse other questions tagged or ask your own question.