So after 16.10 texmaker has been rather reluctant to cooperate with me and I'm forced to use gedit, not that I mind, I use gedit for everything else, but I miss some of texmakers features, in particular the "f1" compile and run. I'm looking for something along the lines: pdflatex tex | evince pdf. You can tell from the previous code example that I'm not very fluent with linux:). Also I did some search around and found this french guy making a script to get it to work, which is basically what I need, but I couldn't get it to work after copying the text (ofc after translation). Any help would be more than welcome!

Edit: a sort-of-fix is ofcourse to make an alias x=pdflatex *.tex;evince *.pdf &, which will compile and display any file in you current directory ending with .tex.


There is a gedit plugin gedit-latex-plugin

sudo apt-get install gedit-latex-plugin 

Use the external tool plugin to create access to envice.

  • To install the plugin, go to Edit -> Preferences -> Plugins -> External Tools.
  • To configure the plugin, go to Tools -> Manage External Tools.... A dialog will appear and you can start adding tools.
  • To run tools, go to Tools -> External Tools or use (if applicable) associated shortcut keys.

The dialog then looks like this: External Tools Manager

Then you can start evince directly or write a shell script for all steps together and execute.

  • I can't enable the plugin in gedit in Edit -> Preferences -> Plugins tab. When I try to enable it, it shows a red circle with a white horizontal line in the middle next to the plugin. Do you have any suggestions? – karel Feb 7 '17 at 9:06
  • @karel Ensure that you have rubber installed. It is used for automated document compiling. – aggsol Feb 7 '17 at 10:25
  • Now this is all well, but what is the default button for compiling and running evince? It doesn't say in the meny after installing it. – Thomas Feb 7 '17 at 14:54
  • @aggsol Would you be kind and provide me details on how to setup key bindings for the quick build? askubuntu.com/questions/880868/… describes the current problem after installing the package you provided. Thanks – Thomas Feb 8 '17 at 5:14
  • @Thomas see my edits. – aggsol Feb 8 '17 at 8:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.