2

I have recently updated my google chrome to stable version. Since then I get the following error while visiting some sites like www.google.com

NET::ERR_CERT_WEAK_SIGNATURE_ALGORITHM

How to fix this problem ?

1
  • Which version would that be? – muru Feb 7 '17 at 9:12
15

I was having the same issue this morning after upgrading google-chrome-stable to 56.0.2924.87 and found the following fix:

sudo apt-get install libnss3-1d

Hope it works for you.

1
  • 1
    yes! I almost lost hope. Installed, removed, resinstalled, then went for beta, nothing worked. And then this libnss3-1d. Oh. Great. – ghosh'. Feb 21 '17 at 20:11
0

This error usually appears when you visit a website which according to google chrome is not safe. But since you get this error even on google official website, there should be some problem with the browser itself.

My suggestion is to fully remove the current google-chrome and install a fresh one. Please follow these steps to make sure google-chrome and it's configurations are removed from your system:

sudo rm /etc/apt/sources.list.d/google-chrome*
sudo apt-get purge google-chrome-*

Then, go for installation (I assume you know how to do it since you already have it)

1
  • Thank you @Mostafa Ahangarha for your response , i have done it yesterday couple of time and again do it now but still no luck , getting similar type of error while visiting google.com. – Shakil Feb 8 '17 at 5:44

Not the answer you're looking for? Browse other questions tagged or ask your own question.