0

Here is what I'm getting:

marco@marco-VirtualBox:~$ sudo apt-key adv --keyserver hkp://ha.pool.sks-
keyservers.net --recv-key 421C365BD9FF1F717815A3895523BAEEB01FA116
Executing: gpg --ignore-time-conflict --no-options --no-default-keyring --
homedir /tmp/tmp.CPcLK5j7k0 --no-auto-check-trustdb --trust-model always --
keyring /etc/apt/trusted.gpg --primary-keyring /etc/apt/trusted.gpg -
keyserver hkp://ha.pool.sks-keyservers.net --recv-key 
421C365BD9FF1F717815A3895523BAEEB01FA116
gpg: requesting key B01FA116 from hkp server ha.pool.sks-keyservers.net
gpg: keyserver timed out
gpg: keyserver receive failed: keyserver error

And here's what I have tried:

-forcing through :80 port in case firewall was blocking the default one.
     >>> did not work

-iptables -A INPUT -p tcp -d 0/0 -s 0/0 --dport 80 -j ACCEPT
-iptables -A INPUT -p tcp -d 0/0 -s 0/0 --dport 11371 -j ACCEPT
     >>> did not work

- sudo ufw disable (disable firewall)
     >>> did not work

The only thing that I can think of at this point is something I read on another post where someone suggested accessing the server manually and copying the key contents into a textfile and adding it authenticate in on my system. But I do not know how to access the server directly.

Appreciate any help!

0

This https://askubuntu.com/a/575130/650485 solved my problem. All I had to do was make sure uncomment a line in /etc/gai.conf and that fixed it.

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.