17

I've just installed AMDGPU-PRO 16.60 in my system and after rebooting I can't login anymore. The LightDM is always restarting.

The Xorg.0.log error is:

[ 46.106] (EE) AIGLX error: dlopen of /usr/lib/x86_64-linux-gnu/dri/i965_dri.so failed (/usr/lib/x86_64-linux-gnu/dri/i965_dri.so: undefined symbol: is64bitelf) 
[ 46.106] (EE) AIGLX: reverting to software rendering 
[ 46.118] (EE) AIGLX error: dlopen of /usr/lib/x86_64-linux-gnu/dri/swrast_dri.so failed (/usr/lib/x86_64-linux-gnu/dri/swrast_dri.so: undefined symbol: is64bitelf) 
[ 46.118] (EE) GLX: could not load software renderer

According to http://support.amd.com/en-us/kb-articles/Pages/AMDGPU-PRO-Driver-for-Linux-Release-Notes.aspx my discrete video card (R7 M265) is supported but I can't figure out how to get it working properly.

My problem is a bit different of Black screen on boot after AMDGPU-Pro install (16.04) because I'm not receiving a black screen. Lightdm is starting but after entering the password, I'm receiving the lightdm login screen again.

3
  • did you try disabling the intel graphics?
    – WooJoo
    Feb 6, 2017 at 19:26
  • Possible duplicate of Black screen on boot after AMDGPU-Pro install (16.04)
    – user589808
    Feb 6, 2017 at 19:45
  • 2
    @CelticWarrior I'm not ready to dupe this question to anything because AMDGPU-Pro 16.60 is a brand new driver, the first AMDGPU-Pro graphics driver for Ubuntu 16.04 to go out of beta. Even so this question has worked in the past for a login loop problem after installing a graphics driver: Ubuntu gets stuck in a login loop, so it's worth taking a look at.
    – karel
    Feb 7, 2017 at 7:16

3 Answers 3

10

EDIT: I managed to fix my problem by installing the px and compute packages for amdgpu-pro (though I doubt the compute packages made the difference).

From the installation folder, run:

amdgpu-pro-install --px

You will be prompted for confirmation twice -- once to uninstall, and once to install. Then reboot.

OLD (semi-)answer:

It looks like the screen is running from the Intel graphics card (i915). Does your laptop have switchable graphics?

As a temporary fix, you can try running a window manager without a compositor -- I've found that Xmonad works fine in my setup. Though anything 3D-accellerated will not work.

I am facing a similar problem (same symptoms) on my laptop, which has Intel graphics. It seems the packages installed by amdgpu-pro are incompatible with the non-AMD drivers included in Ubuntu, looking for this is64bitelf symbol.

This is also described here: undefined symbol: is64bitelf

5
  • Awesome man! Now it's running fine! Mar 1, 2017 at 16:25
  • I have R9 390 and sadly this did not fix it for me.
    – Krym
    Mar 31, 2017 at 12:16
  • @krym Can you paste the contents of /var/log/Xorg.0.log?
    – ahmad
    Apr 2, 2017 at 22:08
  • I tried do use the --px option but I got this error: "E: Impossible de trouver le paquet xserver-xorg-video-modesetting-amdgpu-pro" or in English "unable to find packet...". This packet is nowhere to be found. How did you do it?
    – hyamanieu
    Jan 28, 2018 at 13:37
  • Solved the same issue on Ubuntu 18.04. thanks a ton
    – Morse
    May 7, 2018 at 0:53
5

I had the same symptom. I'm running NVIDIA and AMD RX580. Using --px didn't do it for me. I had to install with the ./amdgpu-pro-install --compute option only.

I'm not using the rx580 for a display.

5

Press Ctrl+Alt+F1 to open the shell. Now you can login and navigate to the amdgpu setup folder.

Now type this:

./amdgpu-pro-install --px

And hit return.

This issue arises, when the AMD graphics card conflicts with the inbuilt or on-motherboard graphics driver. The command above will first uninstall the previous installation and then reinstall with --px parameter.

4
  • I tried do to that but I got this error: "E: Impossible de trouver le paquet xserver-xorg-video-modesetting-amdgpu-pro" or in English "unable to find packet...". This packet is nowhere to be found. How did you do it?
    – hyamanieu
    Jan 28, 2018 at 13:36
  • @Wli i got the same problem, did you fix it ? Jan 28, 2018 at 16:37
  • Nope, i posted my a new question and I've been told I'm off topic.
    – hyamanieu
    Jan 28, 2018 at 17:21
  • This fixed for me! I'd give you 10 points but only can give 1 :)
    – ianaz
    Mar 3, 2018 at 9:26

This site is temporarily in read-only mode and not accepting new answers.

Not the answer you're looking for? Browse other questions tagged .