0

I have a problem with Ubuntu. So, I have installed Ubuntu 16.04 on my usb. Now, I decided to test it one of my computers. So, I did and it worked perfectly.

Then I got my Surface Pro 4 and tried it on there. I selected the "Try it first" option. So Ubuntu starts loading up.

When it finishes it shows the control list. I try to press the "X" button at the top right but the mouse doesn't work at all. I try one of the commands to open up the terminal. The keyboard doesn't work. I try the touch screen. Nothing. Not even the volume buttons work.

I don't know if this helps, but my other computer is 32 bit and my Surface Pro 4 is 64 bit. I'm not sure what to do.

In case you need to know, I am not dual booting, I am just running using a USB.

Please help,

Thank you

2 Answers 2

1

Good eve, I've learned the hard way. I have yakkety running on SP4.

The very short version: update kernel to latest v4.10-rc8 (release candidate). The keyboard / mouse both function (!).

There's also a program called ukuu I highly recommend you install to EASILY update your kernel.

Everything works after you reboot.

HTH,

MarkB (triple booting WIN10, Ubuntu, Mint)

1
  • do you have any changelog at hand?
    – user190080
    Feb 19, 2017 at 3:43
1

I'm brand new to Ubuntu and I got my SP4 working with Ubuntu 16.04LTS using the instructions here https://www.reddit.com/r/SurfaceLinux/comments/4t64zt/getting_the_sp4_running_with_ubuntu_1604/

The site recommends to use fridgecow's kernel but I'd get as far 7b in the instructions and then have issues. Sometimes the system would just freeze but every time at this point the SP4 would no longer restart or shutdown, just sat on the Ubuntu logo and the little dots stopped moving indicating it had stopped. I reinstalled probably 6 times, had to reinstall the grub menu because it disappeared whenever I did a clean install. Booting would just take me to UEFI screen so had to use the liveCD and then recreate the grub menu. There's plenty of sites with instructions how to do that. Was a pain at the start but now it's easy after having done it so many times.

I ended up using 6a and 7a in the instructions and seem to have a really stable build now with the type cover working. I did have to install grub customiser as the touch kernel wasn't the default in grub menu. I had to manually activate the pen via Bluetooth in System Settings and that was easy.

Suspend/hibernate doesn't work and will often not wake at all and needing to do a hard restart. Camera doesn't work either. Apart from that it all seems good, almost ready to put my Ipad 2 in the cupboard as my SP4 is working great as both a tablet and laptop.

I'm not running dual boot, Ubuntu only.

1
  • volume buttons on the SP4 don't work either but they do on the type cover.
    – Brett
    Apr 3, 2017 at 0:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.