4

I have a problem with starting a NEXUS 7 Android 6.0 - API 23 with Genymotion 2.8.1 on Ubuntu 16.04.

Deploying/creating works fine, initializing works fine, but I get the black screen with "Android" and my whole pc hangs; the only thing that moves is the mouse and I have to reboot with Alt + SysReq keys and type REISUB.

I don't get any output or error message

update When I boot the device from virtualbox itself I get:

A N D R O I D [    1.616947] init: /deb/hw_random not found
[    2.547760] init: Failed to reload policy
[    2.715910] init: /recovery not specified in fstab
[    2.723890] init: cannot find `/system/bin/debuggerd64`, disabling `debuggerd64`
[    2.725612] init: cannot find `/system/bin/install-recovery.sh`, disabling `flash_recovery`

shell@android:/ $ IP Management : 192.168.57.101
1
  • I have the same problem and same system. – Frank Mar 22 '17 at 18:40
1

I have just solved the problem by removing libdrm.so.2 from Genymotion installation dir and rebooting my computer.

If that does not work, you can try to disable GPU open drivers and enable proprietary drivers in System Settings > Software & Updates > Additional Drivers.

Hope this help!

1

I've just fixed this issue.

It's cause on default network of virtual-box that you installed. So this is a solution I paste from Genymotion guide:

Your network adapter may be misconfigured. In this case:
Run VirtualBox.
Open File > Preferences > Network (or VirtualBox > Preferences for macOS).
Check that the adapter IPv4 address is in the same network (192.168.56.0/24 by default) as the DHCP server address, lower address bound and upper address bound. If not, your virtual device cannot start.
You can also remove the Host-only Network by clicking . Genymotion will automatically recreate it at the next virtual device start.

Hope you will happy with this.

0

For me the following worked! I got the hint from Tuan Ngo this answer. Thanks Tuan Ngo

step 1) Remove all the Host-only networks from Host Network Manager list in virtual box.

step 2) Factory reset the installed device on Genymotion (I think this step may not be required)

step 3) Start the device from Genymotion. New Host-only network will automatically created and Genymotion will use it.

Hope it helps!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.