10

I'm getting this error every time I do apt-get update

Ign http://ni.archive.ubuntu.com trusty/multiverse Translation-en_US           
Ign http://ni.archive.ubuntu.com trusty/restricted Translation-en_US           
Ign http://ni.archive.ubuntu.com trusty/universe Translation-en_US             
Reading package lists... Done                                                  
W: Ignoring Provides line with DepCompareOp for package libreoffice-l10n
W: Ignoring Provides line with DepCompareOp for package libreoffice-l10n
W: Ignoring Provides line with DepCompareOp for package libreoffice-l10n
W: Ignoring Provides line with DepCompareOp for package libreoffice-l10n
W: Ignoring Provides line with DepCompareOp for package libreoffice-l10n
W: Ignoring Provides line with DepCompareOp for package libreoffice-l10n
W: Ignoring Provides line with DepCompareOp for package libreoffice-l10n
...
...
...
...
W: Ignoring Provides line with DepCompareOp for package libreoffice-l10n
W: Ignoring Provides line with DepCompareOp for package libreoffice-l10n
W: Ignoring Provides line with DepCompareOp for package libreoffice-l10n
W: You may want to run apt-get update to correct these problems

This error started to show after I upgraded LibreOffice form 5.2 to 5.3 with the LibreOffice PPA: ppa:libreoffice/ppa.

The thing is that everything is working fine. I can update/upgrade the system, I can install packages, delete packages, etc. The problem is just with the error.

I tried: apt-get autoclean, apt-get clean, apt-get autoremove, apt-get install -f, and a lot of other things and nothing removes that ugly error.

  • Have you tried purging your existing libreoffice and completely reinstalling? – Sirajus Salekin Feb 6 '17 at 14:08
  • I just tried that. Removed all installed packages from the PPA. Removed the PPA with "ppa-purge". The error disappears. But after adding the PPA again the error shows up. So it seems the problem is with the PPA. – Carlos Estrada Feb 6 '17 at 14:59
  • Follow the known bug status here : bugs.launchpad.net/ubuntu/+bug/1662227?comments=all – SteoG5972 Feb 10 '17 at 8:28
  • Questions about bugs are off-topic. I'm flagging this question to be closed – MadMike Feb 24 '17 at 12:46
3

According to bug report #1662227 that's because the PPA for LibreOffice doesn't provide translation files for languages aside from English.

You can either

  1. safely ignore this warning message as a mostly cosmetic issue or
  2. remove/disable the LibreOffice PPA and use the packages from Canonical's repositories instead.
| improve this answer | |
  • "2. change to English," does not work, see bug report #1662227 you linked to. – Michael Mar 6 '17 at 1:18
1

Rather than downloading from PPA, you can try installing it using snap.

sudo snap install libreoffice

to enable snap packages in 14.04 run

sudo apt-get install snapd

Sources: libreoffice 5.3 snap package, snap in ubuntu 14.04

Make sure to purge existing installation first.

| improve this answer | |
  • 2
    I know that's an option. But I prefer a PPA for now. I have always used it and it has work fine. I just want to know if it's actually a bug with the PPA or there is something wrong with my system. – Carlos Estrada Feb 6 '17 at 15:57
  • @CarlosEstrada, this user is facing the same problem as you. It seems everyone blamed LO 5.3 – Sirajus Salekin Feb 6 '17 at 16:03
  • I made a report in launchpad. By the way, the snap of libreoffice is working great. Thank you. – Carlos Estrada Feb 6 '17 at 16:24
  • @CarlosEstrada, glad to know that. However, the snap LibreOffice have some bug too, you'll face problems with custom themes, also, some files outside snaps sandbox will be unreachable for LibreOffice. – Sirajus Salekin Feb 6 '17 at 16:31
  • snap does not install on 14.04 and it has been like that for a long while – user309383 Mar 11 '19 at 15:08
0

The packages description in debian/control in the PPA is wrong and says the l10n-*-packages for 5.3 would include l10n-5.2.

The package has to be rebuilt; see This Ubuntu Users forum post for a How-To.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.