4

I'm a complete noob to Ubuntu. I have an Asus x540la laptop. before I switched from windows, my touchpad worked just fine, and I was able to perform a right click by tapping on the touchpad with 2 fingers.

On Ubuntu, I don't have smart gesture so I can't do that. The sensitivity is completely off too. Now i frequently accidentally move the cursor while I type and have other problems like that. How do i fix the sensitivity and restore multitouch functionality?

edit: xinput output

⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ FTE1001:00 0B05:0101                      id=10   [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ Sleep Button                              id=8    [slave  keyboard (3)]
    ↳ USB2.0 VGA UVC WebCam                     id=9    [slave  keyboard (3)]
    ↳ Asus WMI hotkeys                          id=11   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=12   [slave  keyboard (3)]
2

I had this issue on many variants of linux. Currently I am on Elementary OS Loki. I had automated the fix of this problem by creating following shell script at /etc/X11/Xsession.d/56touchpadfix:

export `xinput list | grep -i touchpad | awk '{ print $6 }'`
xinput --set-prop "$id" "Synaptics Noise Cancellation" 20 20
xinput --set-prop "$id" "Synaptics Finger" 35 45 250
xinput --set-prop "$id" "Synaptics Scrolling Distance" 180 180
true

You need to tune values for your hardware. Mine work for Sony SVS series laptop.

1

I'm having a similar problem. What should work for you is

xinput set-prop "FTE1001:00 0B05:0101" "Synaptics Noise Cancellation" 20 20
xinput set-prop "FTE1001:00 0B05:0101" "Synaptics Finger" 50 90 255

Taken from this answer.

1

If you have a Dell, there is a solution for this. This may also be applicable even if you do not have a Dell laptop, as long as you update certain steps.

These instructions come directly from Dell in this article Precision / XPS: Ubuntu General Touchpad/Mouse Issue Fix. The issue seems to be that Synaptics drivers override Dell's. You need to disable Synaptics.

The first portion did wonders for me. Here is the script that they suggest adding to sudo gedit /usr/share/X11/xorg.conf.d/51-synaptics-quirks.conf. I do not recommend following the accepted answer's solutions as that route seems to create other problems.

# Disable generic Synaptics device, as we're using
# "DLL0704:01 06CB:76AE Touchpad"
# Having multiple touchpad devices running confuses syndaemon
Section "InputClass"
    Identifier "SynPS/2 Synaptics TouchPad"
    MatchProduct "SynPS/2 Synaptics TouchPad"
    MatchIsTouchpad "on"
    MatchOS "Linux"
    MatchDevicePath "/dev/input/event*"
    Option "Ignore" "on"
EndSection

For compatability comparison, I've a Dell Inspiron 13 7000 series with xinput list

jonathan@Dell:~$ xinput list
⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ Logitech USB Receiver                     id=10   [slave  pointer  (2)]
⎜   ↳ Logitech USB Receiver                     id=11   [slave  pointer  (2)]
⎜   ↳ ELAN Touchscreen                          id=13   [slave  pointer  (2)]
⎜   ↳ DELL0741:00 06CB:7E7E Touchpad            id=14   [slave  pointer  (2)]
...

Synaptics is not on that list because it has been disabled by the above script. Before adding this script, I suggest running xinput --test <id>" (for me 14). If you get output on a terminal, that means your device is working (your device is "on").

After rebooting, you will then need to install libinput with the following command sudo apt-get install xserver-xorg-input-libinput libinput-tools.

After libinput installation, you'll need to update sudo gedit /usr/share/X11/xorg.conf.d/90-libinput.conf per your preferrences. Here is mine for example

# Match on all types of devices but tablet devices and joysticks
Section "InputClass"
        Identifier "libinput pointer catchall"
        MatchIsPointer "on"
        MatchDevicePath "/dev/input/event*"
        Driver "libinput"
EndSection

Section "InputClass"
        Identifier "libinput keyboard catchall"
        MatchIsKeyboard "on"
        MatchDevicePath "/dev/input/event*"
        Driver "libinput"
EndSection

Section "InputClass"
        Identifier "libinput touchpad catchall"
        MatchIsTouchpad "on"
        MatchDevicePath "/dev/input/event*"
    Option "Tapping" "True"
    Option "TapingDrag" "True"
    Option "DisableWhileTyping" "True"
    Option "AccelProfile" "adaptive"
    Option "NaturalScrolling" "True"
    Option "AccelSpeed" "0.2"
        Driver "libinput"
EndSection

Section "InputClass"
        Identifier "libinput touchscreen catchall"
        MatchIsTouchscreen "on"
        MatchDevicePath "/dev/input/event*"
        Driver "libinput"
EndSection

And that's it, no more sensitive touchpad!

  • Thanks for this great solution. Note you need to run "sudo apt-get install xserver-xorg-input-libinput-hwe-16.04 libinput-tools" if you are on 16.04 – max Jun 18 '18 at 13:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.