1

I was trying to learn to create and use .deb file. I added those libs as dependencies to that .deb file under DEBIAN/control file

Package: mydeb
Version: 1.0-1
Section: base
Priority: optional
Architecture: amd64
Depends: ipython (>= 2.4.1-1), decorator (>= 4.0.10), cycler (>= 0.10.0), Cython (>= 0.25.1), dask (>= 0.12.0), imageio (>= 1.6), matplotlib (>= 1.5.3), networkx (>= 1.11), numpy (>= 1.11.2), Pillow (>= 3.4.2), pip (>= 9.0.1), pyglet (>= 1.2.4), pymongo (>= 3.4.0), pyparsing (>= 2.1.10), python-dateutil (>= 2.6.0), pytz (>= 2016.7), requests (>= 2.12.1), scikit-image (>= 0.12.3), scipy (>= 0.18.1), setuptools (>= 28.8.0), six (>= 1.10.0), toolz (>= 0.8.0), wheel (>= 0.30.0a0)         
Maintainer: xxx
Description: xxx

but after I installed that sample .deb file, I have started to see that error during these commands

sudo apt-get update & upgrade

The errors, I am getting are

username@ubuntu:~$ sudo apt-get upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
                   <my deb file > : Depends: decorator (>= 4.0.10) but it is not installable
                   Depends: cycler (>= 0.10.0) but it is not installable
                   Depends: cython (>= 0.25.1) but 0.23.4-0ubuntu5 is installed
                   Depends: dask (>= 0.12.0) but it is not installable
                   Depends: imageio (>= 1.6) but it is not installable
                   Depends: matplotlib (>= 1.5.3) but it is not installable
                   Depends: networkx (>= 1.11) but it is not installable
                   Depends: numpy (>= 1.11.2) but it is not installable
                   Depends: pillow (>= 3.4.2) but it is not installable
                   Depends: pip (>= 9.0.1) but it is not installable
                   Depends: pyglet (>= 1.2.4) but it is not installable
                   Depends: pymongo (>= 3.4.0) but it is not installable
                   Depends: pyparsing (>= 2.1.10) but it is not installable
                   Depends: python-dateutil (>= 2.6.0) but 2.4.2-1 is installed
                   Depends: pytz (>= 2016.7) but it is not installable
                   Depends: requests (>= 2.12.1) but it is not installable
                   Depends: scikit-image (>= 0.12.3) but it is not installable
                   Depends: scipy (>= 0.18.1) but it is not installable
                   Depends: setuptools (>= 28.8.0) but it is not installable
                   Depends: six (>= 1.10.0) but it is not installable
                   Depends: toolz (>= 0.8.0) but it is not installable
                   Depends: wheel (>= 0.30.0a0) but it is not installable

somehow those libs integrate themselves to package manager and that is started to become problem after installing my .deb package. Those libs are already installed on my system.

How do I reset my package manager or overcome this problem?

Thank you

  • Did you run sudo 'apt-get -f install as recommended by apt? – George Udosen Feb 6 '17 at 4:55
  • yes, you are right.somehow I ignored the recommendation. Now everything working good. But have a question how an external .deb package is able to broke my package manager? Those libs are already installed on my system. Thank you! – enterbutton Feb 6 '17 at 6:08
  • deb file will only break it if the deb file your created isn't done right. Not an expert on this but please run these deb or test them in a virtual machine before actually doing them in your live system. That's how to learn else you will always get into trouble. – George Udosen Feb 6 '17 at 6:20
  • Got you, that package still needs to be improved. Thank you for the explanation! @George – enterbutton Feb 6 '17 at 6:24
  • Is this on Ubuntu 16.04 ? The first one "cycler" already cannot be found with that name here : ~ $ apt-cache search cycler bicyclerepair - A refactoring tool for python python-cycler - composable kwarg iterator (Python 2) python3-cycler - composable kwarg iterator (Python 3) – albert j Feb 6 '17 at 6:46
0
sudo apt-get -f install

this command is solved the problem! Thank you @George

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for?Browse other questions tagged or ask your own question.