1

Some directories are highlighted green in my ll list so that it becomes unreadable. How can I switch that off?

enter image description here

I tried to upload a screenshot, but it wont show it... I hope my question is still clear

So, I tried to change it following How do I change the color for directories with ls in the console?

I went through all the types in the list

di = directory
fi = file
ln = symbolic link
pi = fifo file
so = socket file
bd = block (buffered) special file
cd = character (unbuffered) special file
or = symbolic link pointing to a non-existent file (orphan)
mi = non-existent file pointed to by a symbolic link (visible when you type    ls -l)
ex = file which is executable (ie. has 'x' set in permissions).
*.rpm = files with the ending .rpm

but that type did not change. it actually is a directory. for some reasons there seem to be two styles for directories. one is just dark blue no background, the other one has the green background that makes it unreadable. the di option only changes the directories that are dark blue and readable. Ideally I would avoid having a solution that removes all highlighting like ll --color=none. I would prefer to just get rid of that background The unreadable directories have the signature drwxrwxrwx, while the readable ones have drwxr-xr-x

3
  • The one you want is probably ow (other-writable), I'll update the other post once I get a reference
    – muru
    Feb 6, 2017 at 3:15
  • ah, thanks. ow is indeed the type of those directories. I could change it now with LS_COLORS=$LS_COLORS:'ow=1;33' ; export LS_COLORS
    – chrise
    Feb 6, 2017 at 3:26
  • As an aside, I hope you have a good reason for all those 777 permissions ;)
    – Zanna
    Feb 6, 2017 at 3:31

1 Answer 1

2

ll is an alias defined in ~/.bashrc along with other alias's that use color:

# enable color support of ls and also add handy aliases
if [ -x /usr/bin/dircolors ]; then
    test -r ~/.dircolors && eval "$(dircolors -b ~/.dircolors)" || eval "$(dircolors -b)"
    alias ls='ls --color=auto'
    #alias dir='dir --color=auto'
    #alias vdir='vdir --color=auto'

    alias grep='grep --color=auto'
    alias fgrep='fgrep --color=auto'
    alias egrep='egrep --color=auto'
fi

# some more ls aliases
alias ll='ls -alF'
alias la='ls -A'
alias l='ls -CF'

# Add an "alert" alias for long running commands.  Use like so:
#   sleep 10; alert
alias alert='notify-send --urgency=low -i "$([ $? = 0 ] && echo terminal || echo error)" "$(history|tail -n1|sed -e '\''s/^\s*[0-9]\+\s*//;s/[;&|]\s*alert$//'\'')"'

# Add a "redalert" alias to pop-up on GUI desktop screens.  Use like so:
#   redalert "Weather update: It's raining Red States"
alias redalert='notify-send --urgency=critical -i "$([ $? = 0 ] && echo terminal || echo error)" "$(history|tail -n1|sed -e '\''s/^\s*[0-9]\+\s*//;s/[;&|]\s*alert$//'\'')"'

The last Alias: redalert I added manually and is not in normal Ubuntu distributions.

What you can do if you want no colors is use:

sudo chmod -x /usr/bin/dircolors

However in your case you might be looking at a windows partition, ie:

windows directory

In which case you can simply use \ls -alF for no colors:

ls no colors

1
  • when I use \ls -laF it works but I get ls: cannot read symbolic link 'My Music': Permission denied. Is there another way? Jan 5, 2020 at 17:32

Not the answer you're looking for? Browse other questions tagged or ask your own question.